xenomai: add error handling to for loop
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:18:39 +0000 (15:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 23:15:00 +0000 (00:15 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/xenomai/xenomai.mk

index 740a40b96e49060035171da56f21bdeae19a39c3..ccbae358640bc05c751df84e537369f4e115cfc9 100644 (file)
@@ -99,7 +99,7 @@ XENOMAI_DEPENDENCIES += udev
 define XENOMAI_INSTALL_UDEV_RULES
        if test -d $(TARGET_DIR)/etc/udev/rules.d ; then \
                for f in $(@D)/ksrc/nucleus/udev/*.rules ; do \
-                       cp $$f $(TARGET_DIR)/etc/udev/rules.d/ ; \
+                       cp $$f $(TARGET_DIR)/etc/udev/rules.d/ || exit 1 ; \
                done ; \
        fi;
 endef