linux: build after intel-microcode if enabled for early loading support
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 20 May 2019 22:17:11 +0000 (00:17 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 24 May 2019 21:15:38 +0000 (23:15 +0200)
To support building in (a subset of) the intel-microcode files into the
kernel using the CONFIG_EXTRA_FIRMWARE option, we need to ensure that the
microcode files are installed before the Linux kernel is built.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
linux/linux.mk

index 51fd41fa157f97cfcc55624673c3d2b0769f0580..dd182d06b2e6c577ae76770d0aa7184ef736a091 100644 (file)
@@ -64,7 +64,8 @@ LINUX_MAKE_ENV = \
        BR_BINARIES_DIR=$(BINARIES_DIR)
 
 LINUX_INSTALL_IMAGES = YES
-LINUX_DEPENDENCIES = host-kmod
+LINUX_DEPENDENCIES = host-kmod \
+       $(if $(BR2_PACKAGE_INTEL_MICROCODE),intel-microcode)
 
 # Starting with 4.16, the generated kconfig paser code is no longer
 # shipped with the kernel sources, so we need flex and bison, but