package/qt5: drop 5.6 support
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 26 Feb 2020 14:45:32 +0000 (15:45 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 27 Feb 2020 22:50:30 +0000 (23:50 +0100)
As discussed during the FOSDEM2019 develop days, Qt 5.6 is very old (5.6.3
was released in September 2017, and 5.6.x became EOL in March 2019), so drop
it before the new Buildroot LTS release:

https://elinux.org/Buildroot:DeveloperDaysFOSDEM2019#Qt5_versions_to_support:_keep_5.6_or_a_newer_LTS.3F

And add legacy handling for it.

There are a number of places where code checks for
BR2_PACKAGE_QT5_VERSION_LATEST, so leave that as a blind option for now to
not break the build.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/qt5/Config.in
package/qt5/qt5.mk

index 87966facb4dd311b078f81321a57d9ac731fcff5..6a33ce9e1c2436b3a7b4223f9d8b04b99b8d5d95 100644 (file)
@@ -146,6 +146,13 @@ endif
 
 comment "Legacy options removed in 2020.02"
 
+config BR2_PACKAGE_QT5_VERSION_5_6
+       bool "qt 5.6 support removed"
+       select BR2_LEGACY
+       help
+         Support for Qt 5.6 is EOL and has been removed. The current
+         version (5.12 or later) has been selected instead.
+
 config BR2_PACKAGE_CURL
        bool "BR2_PACKAGE_CURL was renamed"
        select BR2_PACKAGE_LIBCURL_CURL
index def79fa680b33389e65859bd506338d469f13bdf..7051bf517a069890e6f649434265fe513eff3134 100644 (file)
@@ -11,14 +11,22 @@ config BR2_PACKAGE_QT5_JSCORE_AVAILABLE
        # ARM needs BLX, so v5t+
        depends on !BR2_ARM_CPU_ARMV4
 
-comment "Qt5 needs a toolchain w/ wchar, NPTL, C++, dynamic library"
-       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS_NPTL || BR2_STATIC_LIBS
+comment "Qt5 needs a toolchain w/ gcc >= 4.8, wchar, NPTL, C++, dynamic library"
+       depends on !BR2_ARM_CPU_ARMV4
+       depends on !BR2_arc && !BR2_nios2 && !BR2_xtensa
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
+               !BR2_TOOLCHAIN_HAS_THREADS_NPTL || BR2_STATIC_LIBS || \
+               !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
 
 menuconfig BR2_PACKAGE_QT5
        bool "Qt5"
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_USE_WCHAR
        depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # C++11
+       depends on !BR2_ARM_CPU_ARMV4 # needs ARMv5+
+       # no built-in double-conversion support
+       depends on !BR2_arc && !BR2_nios2 && !BR2_xtensa
        depends on !BR2_STATIC_LIBS
        select BR2_PACKAGE_QT5BASE
        help
@@ -29,31 +37,9 @@ menuconfig BR2_PACKAGE_QT5
 
 if BR2_PACKAGE_QT5
 
-choice
-       prompt "Qt5 version"
-
 config BR2_PACKAGE_QT5_VERSION_LATEST
-       bool "Latest (5.12)"
-       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # C++11
-       depends on !BR2_ARM_CPU_ARMV4 # needs ARMv5+
-       # no built-in double-conversion support
-       depends on !BR2_arc && !BR2_nios2 && !BR2_xtensa
-       help
-         This option builds Qt 5.12, which is licensed under
-         (L)GPL-3.0+.
-
-comment "Latest Qt version needs a toolchain w/ gcc >= 4.8"
-       depends on !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
-       depends on !BR2_ARM_CPU_ARMV4
-       depends on !BR2_arc && !BR2_nios2 && !BR2_xtensa
-
-config BR2_PACKAGE_QT5_VERSION_5_6
-       bool "LTS (5.6)"
-       help
-         This option builds Qt 5.6, which is licensed under
-         (L)GPL-2.0+.
-
-endchoice
+       bool
+       default y
 
 source "package/qt5/qt53d/Config.in"
 source "package/qt5/qt5base/Config.in"
index d94d9cc99fbfd39a634529bea4737dda3b483a25..7805b575f563d1be7699ba6a1022024aa6dea703 100644 (file)
@@ -4,15 +4,9 @@
 #
 ################################################################################
 
-ifeq ($(BR2_PACKAGE_QT5_VERSION_LATEST),y)
 QT5_VERSION_MAJOR = 5.12
 QT5_VERSION = $(QT5_VERSION_MAJOR).7
 QT5_SOURCE_TARBALL_PREFIX = everywhere-src
-else
-QT5_VERSION_MAJOR = 5.6
-QT5_VERSION = $(QT5_VERSION_MAJOR).3
-QT5_SOURCE_TARBALL_PREFIX = opensource-src
-endif
 QT5_SITE = https://download.qt.io/archive/qt/$(QT5_VERSION_MAJOR)/$(QT5_VERSION)/submodules
 
 include $(sort $(wildcard package/qt5/*/*.mk))