projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
0278ba3
)
libevent: fix openssl detection when statically linking
author
Peter Korsgaard
<peter@korsgaard.com>
Fri, 27 Feb 2015 07:54:33 +0000
(08:54 +0100)
committer
Peter Korsgaard
<peter@korsgaard.com>
Fri, 27 Feb 2015 07:54:33 +0000
(08:54 +0100)
Fixes (indirectly):
http://autobuild.buildroot.net/results/dbf/
dbf2d348de3831a86728f9d72cb56b9f2ddbf554
/
http://autobuild.buildroot.net/results/6a8/
6a89183e558e4ff27841c3e544687ad4a04fb036
/
http://autobuild.buildroot.net/results/c80/
c80eedb4d7335f1aef736a1312900c2b371eabc9
/
http://autobuild.buildroot.net/results/91b/
91b4ab54ed9d422bfaef765d09cc92192012ce7e
/
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libevent/libevent.mk
patch
|
blob
|
history
diff --git
a/package/libevent/libevent.mk
b/package/libevent/libevent.mk
index c50b1d29f2b086d4e32c9deb1fda3f1104733ae8..d67c73833bf1a0f548245e3f77daf25ce5137837 100644
(file)
--- a/
package/libevent/libevent.mk
+++ b/
package/libevent/libevent.mk
@@
-26,6
+26,11
@@
endif
ifeq ($(BR2_PACKAGE_OPENSSL),y)
LIBEVENT_DEPENDENCIES += openssl
LIBEVENT_CONF_OPTS += --enable-openssl
+# openssl needs zlib but configure forgets to link against it causing
+# openssl detection to fail
+ifeq ($(BR2_STATIC_LIBS),y)
+LIBEVENT_CONF_ENV += OPENSSL_LIBADD='-lz'
+endif
else
LIBEVENT_CONF_OPTS += --disable-openssl
endif