lockdev: add lockdev
authorSpenser Gilliland <spenser@gillilanding.com>
Wed, 8 May 2013 18:55:26 +0000 (13:55 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 29 Jul 2013 19:23:04 +0000 (21:23 +0200)
Add lockdev a package for locking devices.

[Thomas: change location in menuconfig, reformat header in .mk file.]

Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/lockdev/Config.in [new file with mode: 0644]
package/lockdev/lockdev.mk [new file with mode: 0644]

index ed373def7fe9ba49de9e354bf4c3224cd0c7caa0..5189b23eba114f9624bf49597efbe39ef1c14c09 100644 (file)
@@ -443,6 +443,7 @@ source "package/libconfuse/Config.in"
 source "package/libfuse/Config.in"
 source "package/liblockfile/Config.in"
 source "package/libsysfs/Config.in"
+source "package/lockdev/Config.in"
 endmenu
 
 menu "Graphics"
diff --git a/package/lockdev/Config.in b/package/lockdev/Config.in
new file mode 100644 (file)
index 0000000..4b386f4
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LOCKDEV
+       bool "lockdev"
+       help
+         Library for locking devices.
+
+         No upstream site, primary site is Debian.
diff --git a/package/lockdev/lockdev.mk b/package/lockdev/lockdev.mk
new file mode 100644 (file)
index 0000000..004b637
--- /dev/null
@@ -0,0 +1,41 @@
+################################################################################
+#
+# lockdev
+#
+################################################################################
+
+LOCKDEV_VERSION = 1.0.3
+LOCKDEV_SOURCE = lockdev_$(LOCKDEV_VERSION).orig.tar.gz
+LOCKDEV_SITE = http://snapshot.debian.org/archive/debian/20130508T154517Z/pool/main/l/lockdev/
+LOCKDEV_LICENSE = LGPLv2.1
+LOCKDEV_LICENSE_FILES = LICENSE
+LOCKDEV_INSTALL_STAGING = YES
+
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+define LOCKDEV_BUILD_CMDS
+       $(MAKE1) $(TARGET_CONFIGURE_OPTS) -C $(@D) static
+endef
+
+define LOCKDEV_INSTALL_STAGING_CMDS
+       $(MAKE1) basedir=$(STAGING_DIR)/usr -C $(@D) install_dev
+endef
+
+else # BR2_PREFER_STATIC_LIB
+
+define LOCKDEV_BUILD_CMDS
+       $(MAKE1) $(TARGET_CONFIGURE_OPTS) -C $(@D) static shared
+endef
+
+define LOCKDEV_INSTALL_STAGING_CMDS
+       $(MAKE1) basedir=$(STAGING_DIR)/usr -C $(@D) install_dev install_run
+       ln -sf liblockdev.$(LOCKDEV_VERSION).so $(STAGING_DIR)/usr/lib/liblockdev.so
+       ln -sf liblockdev.$(LOCKDEV_VERSION).so $(STAGING_DIR)/usr/lib/liblockdev.so.1
+endef
+
+define LOCKDEV_INSTALL_TARGET_CMDS
+       $(MAKE1) basedir=$(TARGET_DIR)/usr -C $(@D) install_run
+       ln -sf liblockdev.$(LOCKDEV_VERSION).so $(STAGING_DIR)/usr/lib/liblockdev.so.1
+endef
+endif # BR2_PREFER_STATIC_LIB
+
+$(eval $(generic-package))