wpa_supplicant: add option to enable syslog support
authorSven Neumann <neumann@teufel.de>
Wed, 11 Dec 2013 13:17:23 +0000 (14:17 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 11 Dec 2013 21:11:00 +0000 (22:11 +0100)
Add an option to enable support for sending debug messages
to syslog instead of stdout.

Signed-off-by: Sven Neumann <neumann@teufel.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/wpa_supplicant/Config.in
package/wpa_supplicant/wpa_supplicant.mk

index 8b0b366936f6e4730bc8deb35271565607f03a51..74145f186074008094280667d56d8ca287c859f9 100644 (file)
@@ -49,6 +49,11 @@ config BR2_PACKAGE_WPA_SUPPLICANT_DBUS_INTROSPECTION
        help
          Add introspection support for new DBus control interface.
 
+config BR2_PACKAGE_WPA_SUPPLICANT_DEBUG_SYSLOG
+       bool "Enable syslog support"
+       help
+         Enable support for sending debug messages to syslog
+
 config BR2_PACKAGE_WPA_SUPPLICANT_WPS
        bool "Enable support for WPS"
        help
index 4ae41c10f780cb3cc6ecf425a56d142b2efe379d..920f96a17863f9eb09e94835672725c9f1bef7cd 100644 (file)
@@ -116,6 +116,12 @@ endef
 
 endif
 
+ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_DEBUG_SYSLOG),y)
+define WPA_SUPPLICANT_DEBUG_CONFIG
+       $(SED) 's/\(#\)\(CONFIG_DEBUG_SYSLOG.*\)/\2/' $(WPA_SUPPLICANT_CONFIG)
+endef
+endif
+
 define WPA_SUPPLICANT_CONFIGURE_CMDS
        cp $(@D)/wpa_supplicant/defconfig $(WPA_SUPPLICANT_CONFIG)
        $(SED) 's/\(#\)\(CONFIG_HS20.*\)/\2/' $(WPA_SUPPLICANT_CONFIG)
@@ -133,6 +139,7 @@ define WPA_SUPPLICANT_CONFIGURE_CMDS
        $(WPA_SUPPLICANT_LIBNL_CONFIG)
        $(WPA_SUPPLICANT_DBUS_CONFIG)
        $(WPA_SUPPLICANT_AP_CONFIG)
+       $(WPA_SUPPLICANT_DEBUG_CONFIG)
 endef
 
 define WPA_SUPPLICANT_BUILD_CMDS