package/libplatform: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 22 Jul 2015 20:30:24 +0000 (22:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 30 Jul 2015 07:29:23 +0000 (09:29 +0200)
Needed by libcec 3.x

[Thomas:
  - adjust licensing information: license is not GPLv3+, but GPLv2+
    plus one source file in PHP license v3.01.
  - add proper license files.
  - remove the -DCMAKE_MODULE_PATH=$(STAGING_DIR)/usr/lib/kodi since
    it doesn't seem to be necessary
  - add patch to fix invalid header and library paths in
    platform-config.cmake.]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/libplatform/0001-platform-config.cmake-fix-paths-for-cross-compilatio.patch [new file with mode: 0644]
package/libplatform/Config.in [new file with mode: 0644]
package/libplatform/libplatform.mk [new file with mode: 0644]

index eba74a051f0710f2145982800f308ecc2d586186..2528238ba5d663061dc076a10cbd7405f0346be7 100644 (file)
@@ -1072,6 +1072,7 @@ menu "Other"
        source "package/liblinear/Config.in"
        source "package/libnspr/Config.in"
        source "package/libpfm4/Config.in"
+       source "package/libplatform/Config.in"
        source "package/libplist/Config.in"
        source "package/libpthread-stubs/Config.in"
        source "package/libpthsem/Config.in"
diff --git a/package/libplatform/0001-platform-config.cmake-fix-paths-for-cross-compilatio.patch b/package/libplatform/0001-platform-config.cmake-fix-paths-for-cross-compilatio.patch
new file mode 100644 (file)
index 0000000..89f35bd
--- /dev/null
@@ -0,0 +1,40 @@
+From 65ba437ed5514dd5762a796d349ed5db49e40fe7 Mon Sep 17 00:00:00 2001
+From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Date: Wed, 29 Jul 2015 21:26:16 +0200
+Subject: [PATCH] platform-config.cmake: fix paths for cross-compilation
+
+Headers and library paths in platform-config.cmake must take into
+account ${CMAKE_FIND_ROOT_PATH} to work in cross-compilation.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ platform-config.cmake.in | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/platform-config.cmake.in b/platform-config.cmake.in
+index 7fe35fe..78b5085 100644
+--- a/platform-config.cmake.in
++++ b/platform-config.cmake.in
+@@ -10,16 +10,16 @@
+ #
+ # propagate these properties from one build system to the other
+ set (platform_VERSION "@platform_VERSION_MAJOR@.@platform_VERSION_MINOR@")
+-set (platform_INCLUDE_DIRS @platform_INCLUDE_DIRS@ @CMAKE_INSTALL_PREFIX@/include)
++set (platform_INCLUDE_DIRS ${CMAKE_FIND_ROOT_PATH}/@platform_INCLUDE_DIRS@ ${CMAKE_FIND_ROOT_PATH}/@CMAKE_INSTALL_PREFIX@/include)
+ set (platform_LIBRARY_DIRS "@CMAKE_LIBRARY_OUTPUT_DIRECTORY@")
+ set (platform_LINKER_FLAGS "@platform_LINKER_FLAGS@")
+ set (platform_CONFIG_VARS "@platform_CONFIG_VARS@")
+ # libraries come from the build tree where this file was generated
+ if(WIN32)
+-  set (platform_LIBRARY "@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_LIBDIR@/platform.lib")
++  set (platform_LIBRARY "${CMAKE_FIND_ROOT_PATH}/@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_LIBDIR@/platform.lib")
+ else(WIN32)
+-  set (platform_LIBRARY "-L@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_LIBDIR@ -lplatform")
++  set (platform_LIBRARY "-L${CMAKE_FIND_ROOT_PATH}/@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_LIBDIR@ -lplatform")
+ endif(WIN32)
+ set (platform_LIBRARIES ${platform_LIBRARY} "@platform_LIBRARIES@")
+ mark_as_advanced (platform_LIBRARY)
+-- 
+2.5.0
+
diff --git a/package/libplatform/Config.in b/package/libplatform/Config.in
new file mode 100644 (file)
index 0000000..7d275b1
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LIBPLATFORM
+       bool
+       help
+         Platform support library used by libCEC and binary add-ons for Kodi
+
+         https://github.com/Pulse-Eight/platform
diff --git a/package/libplatform/libplatform.mk b/package/libplatform/libplatform.mk
new file mode 100644 (file)
index 0000000..4eb934f
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# libplatform
+#
+################################################################################
+
+LIBPLATFORM_VERSION = 1.0.10
+LIBPLATFORM_SITE = $(call github,Pulse-Eight,platform,$(LIBPLATFORM_VERSION))
+LIBPLATFORM_LICENSE = GPLv2+, PHP license v3.01
+LIBPLATFORM_LICENSE_FILES = src/os.h src/util/fstrcmp.c
+LIBPLATFORM_INSTALL_STAGING = YES
+
+$(eval $(cmake-package))