package/python-iwlib: new package
authorJared Bents <jared.bents@rockwellcollins.com>
Mon, 12 Apr 2021 15:20:32 +0000 (10:20 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 21 Apr 2021 21:14:11 +0000 (23:14 +0200)
A package for interfacing with iwlib, providing an implementation to
the wireless tools in Linux.

Signed-off-by: Jared Bents <jared.bents@rockwellcollins.com>
Signed-off-by: Kalpesh Panchal <kalpesh.panchal@rockwellcollins.com>
Signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-iwlib/Config.in [new file with mode: 0644]
package/python-iwlib/python-iwlib.hash [new file with mode: 0644]
package/python-iwlib/python-iwlib.mk [new file with mode: 0644]

index 678c1825ade96a001d36709da8dc3e8b0b9b7c42..95b52d76be1e4918e62d5f5427f9f556851557a8 100644 (file)
@@ -1789,6 +1789,7 @@ F:        package/python-filelock/
 F:     package/python-flask-cors/
 F:     package/python-iptables/
 F:     package/python-ipy/
+F:     package/python-iwlib/
 F:     package/python-posix-ipc/
 F:     package/python-pycairo/
 F:     package/python-pypcap/
index 0d7cb0f446a7922d4401312b4e9941dd00f4c23a..b9d277428d7c57d0249496e897638074492a9cc7 100644 (file)
@@ -1031,6 +1031,7 @@ menu "External python modules"
        source "package/python-ipython-genutils/Config.in"
        source "package/python-iso8601/Config.in"
        source "package/python-itsdangerous/Config.in"
+       source "package/python-iwlib/Config.in"
        source "package/python-janus/Config.in"
        source "package/python-jaraco-classes/Config.in"
        source "package/python-jaraco-functools/Config.in"
diff --git a/package/python-iwlib/Config.in b/package/python-iwlib/Config.in
new file mode 100644 (file)
index 0000000..eb28d67
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PYTHON_IWLIB
+       bool "python-iwlib"
+       depends on BR2_PACKAGE_WIRELESS_TOOLS_LIB
+       help
+         python-iwlib is a package for interfacing with iwlib,
+         providing an implementation to the wireless tools in Linux.
+
+         https://github.com/nhoad/python-iwlib
diff --git a/package/python-iwlib/python-iwlib.hash b/package/python-iwlib/python-iwlib.hash
new file mode 100644 (file)
index 0000000..4d71a3f
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256  7f1ad4354284a452388e178b5d9b191fa5a68a9183423a90a1d261ba2ebd1cac  python-iwlib-1.5.tar.gz
+sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING
diff --git a/package/python-iwlib/python-iwlib.mk b/package/python-iwlib/python-iwlib.mk
new file mode 100644 (file)
index 0000000..9d09855
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-iwlib
+#
+################################################################################
+
+PYTHON_IWLIB_VERSION = 1.5
+PYTHON_IWLIB_SITE = $(call github,nhoad,python-iwlib,$(PYTHON_IWLIB_VERSION))
+PYTHON_IWLIB_LICENSE = GPL-2.0
+PYTHON_IWLIB_LICENSE_FILES = COPYING
+PYTHON_IWLIB_SETUP_TYPE = setuptools
+PYTHON_IWLIB_DEPENDENCIES = wireless_tools
+
+$(eval $(python-package))