package/apr-util: add optional dependency to openssl
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 6 Oct 2014 19:32:09 +0000 (21:32 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 26 Oct 2014 21:52:41 +0000 (22:52 +0100)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/apr-util/apr-util.mk

index fc515a34151f045b6debec5c277a7bd2f8ca2ebe..3b0a71beb925573abc25a7f227e099535e93cd5f 100644 (file)
@@ -46,4 +46,11 @@ else
 APR_UTIL_CONF_OPTS += --without-sqlite3
 endif
 
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+APR_UTIL_CONF_OPTS += --with-crypto --with-openssl="$(STAGING_DIR)/usr"
+APR_UTIL_DEPENDENCIES += openssl
+else
+APR_UTIL_CONF_OPTS += --without-crypto
+endif
+
 $(eval $(autotools-package))