package/pkg-utils.mk: add dl_dir to show-info output
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 3 Aug 2019 14:04:33 +0000 (16:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 25 Sep 2019 19:54:55 +0000 (21:54 +0200)
It can be useful for scripts to be able to access a package's source
file after download. That used to be easy, just DL_DIR/PKG_SOURCE.
However, with the subdirectories in DL_DIR which can be overridden with
PKG_DL_SUBDIR, that is no longer easy.

Therefore, this patch adds dl_dir to the package information. It prints
just PKG_DL_SUBDIR, to avoid dumping absolute paths to the buildroot
directory in the show-info output.

It can be used with the following jq script to get a newline-separated
list of all downloaded files:

make show-info | jq -r '.[] | ("dl/" + .dl_dir + "/" + .downloads[]?.source)'

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Cc: Yann E. MORIN <yann.morin.1998@free.fr>
Acked-by: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pkg-utils.mk

index 74ade437d993fa4b68a51f303d5cdd2414207cf2..63b19e812be2781481d123db422fb2bf472f02f4 100644 (file)
@@ -99,6 +99,7 @@ endef
 define _json-info-pkg-details
        "version": "$($(1)_DL_VERSION)",
        "licenses": "$($(1)_LICENSE)",
+       "dl_dir": "$($(1)_DL_SUBDIR)",
        "install_target": $(call yesno-to-bool,$($(1)_INSTALL_TARGET)),
        "install_staging": $(call yesno-to-bool,$($(1)_INSTALL_STAGING)),
        "install_images": $(call yesno-to-bool,$($(1)_INSTALL_IMAGES)),