squashfs: fix build with gcc 7
authorBaruch Siach <baruch@tkos.co.il>
Tue, 25 Jul 2017 18:28:15 +0000 (21:28 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 31 Jul 2017 17:28:52 +0000 (19:28 +0200)
gcc 7 with -Os (optimize for size) takes the liberty to remove the code of
inline function entirely. This leads to undefined function references at link
time. Restore gcc original inline behaviour to fix this issue.

Fixes:
http://autobuild.buildroot.net/results/3c5/3c5b1d799dce3ba361d618330c242bf4eba76019/
http://autobuild.buildroot.net/results/09f/09f350b62e2486404b78222dce211400bb233000/
http://autobuild.buildroot.net/results/693/693960ed7c01622c756dcc929e83b3b713c16ccc/

Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/squashfs/squashfs.mk

index db3f27648eb6350058fb660ed2afa3ed75e9dec4..9599d892b261ae4f38141b2dd92ba8003b2a1839 100644 (file)
@@ -59,7 +59,7 @@ HOST_SQUASHFS_MAKE_ARGS = \
 define SQUASHFS_BUILD_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) \
                CC="$(TARGET_CC)" \
-               EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+               EXTRA_CFLAGS="$(TARGET_CFLAGS) -fgnu89-inline" \
                EXTRA_LDFLAGS="$(TARGET_LDFLAGS)" \
                $(SQUASHFS_MAKE_ARGS) \
                -C $(@D)/squashfs-tools/