barebox: fix compilation on x86-64 architecture
authorLahoudere Fabien <fabienlahoudere.pro@gmail.com>
Wed, 4 Mar 2015 14:50:46 +0000 (15:50 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 4 Mar 2015 20:38:45 +0000 (21:38 +0100)
Barebox uses KERNEL_ARCH to derive BAREBOX_ARCH, but doesn't
currently handle the case of the x86-64 architecture. In this
case KERNEL_ARCH is x86_64, but BAREBOX_ARCH should be x86
nonetheless.

Signed-off-by: Fabien Lahoudere <fabienlahoudere.pro@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/barebox/barebox.mk

index b829ae720176b7fcdce0261148604874aae7a9fc..5809fb02971536dc78a2a4b2d3b765147c3d2206 100644 (file)
@@ -41,6 +41,8 @@ endif
 
 ifeq ($(KERNEL_ARCH),i386)
 BAREBOX_ARCH = x86
+else ifeq ($(KERNEL_ARCH),x86_64)
+BAREBOX_ARCH = x86
 else ifeq ($(KERNEL_ARCH),powerpc)
 BAREBOX_ARCH = ppc
 else