use which to locate apps (useful for non-Linux systems like OS X)
authorMike Frysinger <vapier@gentoo.org>
Sun, 19 Dec 2004 15:43:03 +0000 (15:43 -0000)
committerMike Frysinger <vapier@gentoo.org>
Sun, 19 Dec 2004 15:43:03 +0000 (15:43 -0000)
toolchain/binutils/binutils.mk

index cdb5f823dc7e6a73f5d05e213867767b966ee395..9841278cfcbf33cf8c93854da138ccf55c03d013 100644 (file)
@@ -58,15 +58,15 @@ $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/ld: $(BINUTILS_DIR1)/binutils/objdump
        $(MAKE) -C $(BINUTILS_DIR1) install
 
 binutils-dependancies:
-       @if [ ! -x /usr/bin/bison ] ; then \
+       @if ! which bison ; then \
                echo -e "\n\nYou must install 'bison' on your build machine\n"; \
                exit 1; \
        fi;
-       @if [ ! -x /usr/bin/flex ] ; then \
+       @if ! which flex ; then \
                echo -e "\n\nYou must install 'flex' on your build machine\n"; \
                exit 1; \
        fi;
-       @if [ ! -x /usr/bin/msgfmt ] ; then \
+       @if ! which msgfmt ; then \
                echo -e "\n\nYou must install 'gettext' on your build machine\n"; \
                exit 1; \
        fi;