python-ws4py: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Sun, 8 Feb 2015 20:56:08 +0000 (21:56 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 31 Mar 2015 22:05:15 +0000 (00:05 +0200)
[Thomas: fix <pkg>_LICENSE_FILES, since there is no file named
'LICENSE' in the tarball.]

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-ws4py/Config.in [new file with mode: 0644]
package/python-ws4py/python-ws4py.hash [new file with mode: 0644]
package/python-ws4py/python-ws4py.mk [new file with mode: 0644]

index 20b0cfcbd5a6dbdec33937beb5bae40d2d1ce787..8cd0cb1b4ad352f4f13b06b92b7147fc59b8e8d0 100644 (file)
@@ -591,6 +591,7 @@ menu "external python modules"
        source "package/python-versiontools/Config.in"
        source "package/python-webpy/Config.in"
        source "package/python-werkzeug/Config.in"
+       source "package/python-ws4py/Config.in"
        source "package/python-zope-interface/Config.in"
 endmenu
 endif
diff --git a/package/python-ws4py/Config.in b/package/python-ws4py/Config.in
new file mode 100644 (file)
index 0000000..f4763a8
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PYTHON_WS4PY
+       bool "python-ws4py"
+       help
+         ws4py is a Python package implementing the WebSocket protocol
+         as defined in RFC 6455.
+
+         https://ws4py.readthedocs.org
diff --git a/package/python-ws4py/python-ws4py.hash b/package/python-ws4py/python-ws4py.hash
new file mode 100644 (file)
index 0000000..e58e14a
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi?:action=show_md5&digest=6b47e33cbd13f5c134b04f2a44a480ad, sha256 locally computed
+md5     6b47e33cbd13f5c134b04f2a44a480ad  ws4py-0.3.4.tar.gz
+sha256  85d5c01bb0d031e151a32fad56094caf54e20c2ddb51cf25b5709421ff92d007  ws4py-0.3.4.tar.gz
diff --git a/package/python-ws4py/python-ws4py.mk b/package/python-ws4py/python-ws4py.mk
new file mode 100644 (file)
index 0000000..f332d15
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-ws4py
+#
+################################################################################
+
+PYTHON_WS4PY_VERSION = 0.3.4
+PYTHON_WS4PY_SOURCE = ws4py-$(PYTHON_WS4PY_VERSION).tar.gz
+PYTHON_WS4PY_SITE = https://pypi.python.org/packages/source/w/ws4py
+PYTHON_WS4PY_SETUP_TYPE = setuptools
+PYTHON_WS4PY_LICENSE = BSD-3c
+PYTHON_WS4PY_LICENSE_FILES = ws4py/__init__.py
+
+$(eval $(python-package))