libssh: fix cross compile with older cmake
authorBaruch Siach <baruch@tkos.co.il>
Wed, 22 Aug 2018 21:58:30 +0000 (00:58 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 23 Aug 2018 09:40:13 +0000 (11:40 +0200)
Old version of cmake break cross-compilation when FindThreads is used
because of a try_run call. Add a workaround that avoids try_run.

cmake bug report: https://gitlab.kitware.com/cmake/cmake/issues/16920

Should fix:
http://autobuild.buildroot.net/results/8aa/8aa2bd894416a4508ca7140f8947ff46243f8b78/
http://autobuild.buildroot.net/results/f2c/f2cc965bb134bf4fd9e625eb267b67c949c202fc/

Cc: Scott Fan <fancp2007@gmail.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libssh/libssh.mk

index 4295aa42ee3b4e268bccd30bfe2179f1e3bd38bb..635d72ad9868d9a2722a1b0777ee86eb2ab34906 100644 (file)
@@ -17,6 +17,9 @@ LIBSSH_CONF_OPTS = \
        -DWITH_SERVER=OFF \
        -DWITH_EXAMPLES=OFF
 
+# cmake older than 3.10 require this to avoid try_run() in FindThreads
+LIBSSH_CONF_OPTS += -DTHREADS_PTHREAD_ARG=OFF
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 LIBSSH_CONF_OPTS += -DWITH_ZLIB=ON
 LIBSSH_DEPENDENCIES += zlib