package/libsvgtiny: fix parallel build
authorGiulio Benetti <giulio.benetti@benettiengineering.com>
Sat, 22 Feb 2020 21:44:39 +0000 (22:44 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 23 Feb 2020 07:48:01 +0000 (08:48 +0100)
Fix previous commit[1] which purpose was to fix parallel build. It
didn't work since it assigned $(MAKE1) to LIBSVGTINY_MAKE, but this is a
generic-package and building is done using $(MAKE), then LIBSVGTINY_MAKE
was ignored. Let's substitute instead $(MAKE) with $(MAKE1) in
LIBSVGTINY_BUILD_CMDS.

[1]:
https://git.buildroot.net/buildroot/commit/?id=26d67a2599d6c88facd5178de853fa355244e7c2

Fixes:
http://autobuild.buildroot.net/results/67d/67d341c0cc272323d6e231a20796a6848c21d760/

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
[yann.morin.1998@free.fr:
  - use $(MAKE1) in all three step
  - move comment out of the define
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libsvgtiny/libsvgtiny.mk

index fe7dc0a6d24f1c0eb75744d811b45aaf9140601d..55ce4327fe7762f840de092a4b392710aef3e3f2 100644 (file)
@@ -12,8 +12,6 @@ LIBSVGTINY_DEPENDENCIES = \
        libxml2 host-gperf host-pkgconf host-netsurf-buildsystem
 LIBSVGTINY_LICENSE = MIT
 LIBSVGTINY_LICENSE_FILES = README
-# Package does not build in parallel due to improper make rules
-LIBSVGTINY_MAKE = $(MAKE1)
 
 # The libsvgtiny build system cannot build both the shared and static
 # libraries. So when the Buildroot configuration requests to build
@@ -28,20 +26,21 @@ define LIBSVGTINY_CONFIGURE_CMDS
        ln -sf $(HOST_DIR)/share/netsurf-buildsystem $(@D)/build
 endef
 
+# Use $(MAKE1) since parallel build fails
 define LIBSVGTINY_BUILD_CMDS
-       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) PREFIX=/usr \
+       $(TARGET_CONFIGURE_OPTS) $(MAKE1) -C $(@D) PREFIX=/usr \
                COMPONENT_TYPE=$(LIBSVGTINY_COMPONENT_TYPE)
 endef
 
 define LIBSVGTINY_INSTALL_STAGING_CMDS
        $(TARGET_CONFIGURE_OPTS) \
-               $(MAKE) -C $(@D) PREFIX=/usr DESTDIR=$(STAGING_DIR) \
+               $(MAKE1) -C $(@D) PREFIX=/usr DESTDIR=$(STAGING_DIR) \
                COMPONENT_TYPE=$(LIBSVGTINY_COMPONENT_TYPE) install
 endef
 
 define LIBSVGTINY_INSTALL_TARGET_CMDS
        $(TARGET_CONFIGURE_OPTS) \
-               $(MAKE) -C $(@D) PREFIX=/usr DESTDIR=$(TARGET_DIR) \
+               $(MAKE1) -C $(@D) PREFIX=/usr DESTDIR=$(TARGET_DIR) \
                COMPONENT_TYPE=$(LIBSVGTINY_COMPONENT_TYPE) install
 endef