ipsec-tools: add option for dead peer detection support
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 10 Feb 2012 12:57:27 +0000 (13:57 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 10 Feb 2012 13:06:23 +0000 (14:06 +0100)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/ipsec-tools/Config.in
package/ipsec-tools/ipsec-tools.mk

index 8a5f3d1e4115316ea61dbba582989e4faeae96df..d4c62c6013c7212842f5e77d93621d278299c508 100644 (file)
@@ -33,6 +33,11 @@ config BR2_PACKAGE_IPSEC_TOOLS_FRAG
          Enable IKE fragmentation, which is a workaround for
          broken routers that drop fragmented packets
 
+config BR2_PACKAGE_IPSEC_TOOLS_DPD
+       bool "Enable DPD (Dead Peer Detection)"
+       help
+         Enable dead peer detection support
+
 config BR2_PACKAGE_IPSEC_TOOLS_STATS
        default y
        bool "Enable statistics logging function."
index 9781f3bea2c2323c345cd994cfab93573027823f..d7f8e3551632cef62174e81e0b7c1a7ac459a593 100644 (file)
@@ -38,6 +38,12 @@ else
 IPSEC_TOOLS_CONF_OPT+= --disable-frag
 endif
 
+ifeq ($(BR2_PACKAGE_IPSEC_TOOLS_DPD), y)
+IPSEC_TOOLS_CONF_OPT+= --enable-dpd
+else
+IPSEC_TOOLS_CONF_OPT+= --disable-dpd
+endif
+
 ifeq ($(BR2_PACKAGE_IPSEC_TOOLS_STATS), y)
 IPSEC_TOOLS_CONF_OPT+= --enable-stats
 else