libpcap: bump to version 0.9.8
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Tue, 7 Oct 2008 07:24:41 +0000 (07:24 -0000)
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Tue, 7 Oct 2008 07:24:41 +0000 (07:24 -0000)
This patch bumps the version to 0.9.8 and refreshes the patch against that
version. Fixes bug #5284.

Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
package/libpcap/libpcap.mk
package/libpcap/libpcap.patch

index af1e62f194f110fcd6431b264d5e621754d19fc6..62def6f460dc9bdbb72b5600094d808c834b38b7 100644 (file)
@@ -21,7 +21,7 @@
 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
 # USA
 
-LIBPCAP_VERSION:=0.9.5
+LIBPCAP_VERSION:=0.9.8
 LIBPCAP_DIR:=$(BUILD_DIR)/libpcap-$(LIBPCAP_VERSION)
 LIBPCAP_SITE:=http://www.tcpdump.org/release
 LIBPCAP_SOURCE:=libpcap-$(LIBPCAP_VERSION).tar.gz
index 196ee34eb3a293976bd3d76e33c99b990710477d..93206946b14a50c187dc39502750f6ab4b02ca1e 100644 (file)
@@ -1,6 +1,8 @@
---- libpcap-0.8.3/Makefile.in.orig     2005-01-17 19:04:41.291056960 -0500
-+++ libpcap-0.8.3/Makefile.in  2005-01-17 19:04:47.836061968 -0500
-@@ -100,7 +100,7 @@
+Index: libpcap-0.9.8/Makefile.in
+===================================================================
+--- libpcap-0.9.8.orig/Makefile.in     2007-07-24 04:35:15.000000000 +0200
++++ libpcap-0.9.8/Makefile.in  2008-10-07 09:23:01.000000000 +0200
+@@ -103,7 +103,7 @@
  
  libpcap.a: $(OBJ)
        @rm -f $@
@@ -8,4 +10,4 @@
 +      $(AR) rc $@ $(OBJ) $(LIBS)
        $(RANLIB) $@
  
- scanner.c: $(srcdir)/scanner.l
+ shared: libpcap.$(DYEXT)