- make sure that the target's usr/include dir exists when installing the headers
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 2 Oct 2007 15:38:27 +0000 (15:38 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 2 Oct 2007 15:38:27 +0000 (15:38 -0000)
  It would make sense to provide a $(PREREQ_TARGETDIR_USR_INCLUDE) prerequisite that expands to $(TARGET_DIR)/usr/include
  if installing any headers was requested to fix this in a generic manner..

package/libelf/libelf.mk

index af06ba8b10e9827af504f513c082de48f8f95f40..51c4b4b1d6ffcf3bc7c34ae16ba578468cf09a8d 100644 (file)
@@ -57,7 +57,9 @@ $(STAGING_DIR)/usr/lib/libelf.a $(STAGING_DIR)/usr/lib/libelf.so.$(LIBELF_VERSIO
 
 ifeq ($(BR2_PACKAGE_LIBELF_HEADERS),y)
 $(TARGET_DIR)/usr/lib/libelf.so.$(LIBELF_VERSION): $(STAGING_DIR)/usr/lib/libelf.a
-       $(INSTALL) $(STAGING_DIR)/usr/lib/libelf* $(@D)
+       mkdir -p $(@D)
+       cp -dpf $(STAGING_DIR)/usr/lib/libelf* $(@D)
+       mkdir -p $(TARGET_DIR)/usr/include
        cp -dpR $(STAGING_DIR)/usr/include/{gelf.h,libelf*} $(TARGET_DIR)/usr/include/
        $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@