package/dovecot: Remove bzip2 and zlib options
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 10 Feb 2016 20:58:17 +0000 (21:58 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 16 Feb 2016 22:06:40 +0000 (23:06 +0100)
The next patch of this series will add optional xz and lz4 support, to
avoid adding new options for these compression packages simplify the
configuration of dovecot by removing the options handling optional
compression support.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in.legacy
package/dovecot/Config.in
package/dovecot/dovecot.mk

index 2fda9f8307da4162ab6f9dea942e59a4b8e7df4d..081bacdd3d921b363495b7723652a6228d10c9f5 100644 (file)
@@ -145,6 +145,20 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2016.02"
 
+config BR2_PACKAGE_DOVECOT_BZIP2
+       bool "bzip2 support option has been removed"
+       select BR2_LEGACY
+       select BR2_PACKAGE_BZIP2
+       help
+         Bzip2 support is built if the bzip2 package is selected.
+
+config BR2_PACKAGE_DOVECOT_ZLIB
+       bool "zlib support option has been removed"
+       select BR2_LEGACY
+       select BR2_PACKAGE_ZLIB
+       help
+         Zlib support is built if the zlib package is selected.
+
 config BR2_PACKAGE_E2FSPROGS_FINDFS
        bool "e2fsprogs findfs option has been removed"
        select BR2_LEGACY
index 3baae6e5615a1bc806043488e89892f2aabe73e8..194efb6bc3d62ce4b305d359814c830c55d8de14 100644 (file)
@@ -13,12 +13,6 @@ config BR2_PACKAGE_DOVECOT
 
 if BR2_PACKAGE_DOVECOT
 
-config BR2_PACKAGE_DOVECOT_BZIP2
-       bool "bzip2 support"
-       select BR2_PACKAGE_BZIP2
-       help
-         Enable bzip2 support.
-
 config BR2_PACKAGE_DOVECOT_MYSQL
        bool "mysql support"
        select BR2_PACKAGE_MYSQL
@@ -43,12 +37,6 @@ config BR2_PACKAGE_DOVECOT_SQLITE
        help
          Enable SQLite support.
 
-config BR2_PACKAGE_DOVECOT_ZLIB
-       bool "zlib support"
-       select BR2_PACKAGE_ZLIB
-       help
-         Enable zlib support.
-
 source package/dovecot-pigeonhole/Config.in
 
 endif # BR2_PACKAGE_DOVECOT
index 8451e52342dc5669915f71faa83a5cdf497ec70e..eea9efcc2fd90c6f76dc708382fce42b46f999e0 100644 (file)
@@ -33,7 +33,7 @@ ifeq ($(BR2_PACKAGE_DOVECOT_MYSQL)$(BR2_PACKAGE_DOVECOT_SQLITE),)
 DOVECOT_CONF_OPTS += --without-sql
 endif
 
-ifeq ($(BR2_PACKAGE_DOVECOT_BZIP2),y)
+ifeq ($(BR2_PACKAGE_BZIP2),y)
 DOVECOT_CONF_OPTS += --with-bzlib
 DOVECOT_DEPENDENCIES += bzip2
 else
@@ -76,7 +76,7 @@ else
 DOVECOT_CONF_OPTS += --without-sqlite
 endif
 
-ifeq ($(BR2_PACKAGE_DOVECOT_ZLIB),y)
+ifeq ($(BR2_PACKAGE_ZLIB),y)
 DOVECOT_CONF_OPTS += --with-zlib
 DOVECOT_DEPENDENCIES += zlib
 else