pinentry: optionally depend on libsecret
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 28 Dec 2015 11:28:35 +0000 (12:28 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 28 Dec 2015 11:28:35 +0000 (12:28 +0100)
pinentry can use libsecret when available, so we should handle this
optional dependencies properly.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pinentry/pinentry.mk

index ab7be54d8866ba2ee72c7bac0ab443a7a030c1d4..09a7705c2765cd356607ac8181527ec20a696bd6 100644 (file)
@@ -21,6 +21,13 @@ else
 PINENTRY_CONF_OPTS += --without-x
 endif
 
+ifeq ($(BR2_PACKAGE_LIBSECRET),y)
+PINENTRY_CONF_OPTS += --enable-libsecret
+PINENTRY_DEPENDENCIES += libsecret
+else
+PINENTRY_CONF_OPTS += --disable-libsecret
+endif
+
 # pinentry-ncurses backend
 ifeq ($(BR2_PACKAGE_PINENTRY_NCURSES),y)
 PINENTRY_CONF_OPTS += --enable-ncurses --with-ncurses-include-dir=none