boost: context needs C++11
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 21 Aug 2018 21:25:47 +0000 (23:25 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 10 Oct 2018 19:50:09 +0000 (21:50 +0200)
Without std=c++11, mutex is not always correctly detected with gcc 4.7,
4.8 or even 5.x. As a result, boost_thread is wrongly selected by
boost_context.

mutex is available on gcc 4.7.x, the issue is that boost does not
correctly detect it because -std=c++11 was missing.
Keep thread select for gcc version lower or equal to 4.6. mutex is
available since gcc 4.4 (with std=c++0x) but common buildroot practice
for C++11 packages is to have a dependency on gcc 4.7, 4.8 or 4.9
depending on the requested C++11 features.

Fixes:
 - http://autobuild.buildroot.net/results/fb046c04fe18bec973d120e4ab33971f32ba5769
 - http://autobuild.buildroot.net/results/99f1a255b78a973faeb8bf3b94d78efc54426a8b

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/boost/Config.in
package/boost/boost.mk

index 389592fd32bfb17e66f9b6a5f358da79e13f03dd..e0bff17f7591daa318b30142b8f3a4edae97290e 100644 (file)
@@ -83,7 +83,7 @@ config BR2_PACKAGE_BOOST_CONTEXT
        bool "boost-context"
        depends on BR2_PACKAGE_BOOST_CONTEXT_ARCH_SUPPORTS
        depends on !BR2_TOOLCHAIN_HAS_GCC_BUG_64735
-       select BR2_PACKAGE_BOOST_THREAD if !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
+       select BR2_PACKAGE_BOOST_THREAD if !BR2_TOOLCHAIN_GCC_AT_LEAST_4_7
        help
          C++11 context switching library.
 
index 0adad8929769437a3df8bf189dd27b59f143729d..2ce6bbb75fb9772c8f05984d057500b7c1df733f 100644 (file)
@@ -61,6 +61,11 @@ else
 BOOST_FLAGS += --without-icu
 endif
 
+# boost-context needs C++11
+ifeq ($(BR2_PACKAGE_BOOST_CONTEXT)$(BR2_TOOLCHAIN_GCC_AT_LEAST_4_7),yy)
+BOOST_TARGET_CXXFLAGS += -std=c++11
+endif
+
 ifeq ($(BR2_PACKAGE_BOOST_IOSTREAMS),y)
 BOOST_DEPENDENCIES += bzip2 zlib
 endif