cmake: forward HOST_{C, LD}FLAGS as cmake flags
authorSamuel Martin <s.martin49@gmail.com>
Fri, 9 May 2014 09:07:27 +0000 (11:07 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 9 May 2014 09:36:35 +0000 (11:36 +0200)
During the CMake bootstrap phase, the {C,LD}FLAGS set in the bootstrap
environment are not forwarded/converted as CMake flags.

The CMake build contains a bootstrap phase building a minimal CMake
program using a standard Makfile, then reconfigures itself with this
minimal program.

On system with no ncurses installed, and because the prefix option
points to $(HOST_DIR)/usr, if host-cmake was built after host-ncurses,
then ncurses libraries and headers are correctly found (in the host
tree) during the second configuration (because of the prefix). However,
it fails at building ccmake (the curses interface) because the
CMAKE_C_FLAGS, CMAKE_CXX_FLAGS and CMAKE_EXE_LINKER_FLAGS do not
point to the host tree.

Because these flags are needed when running the bootstrap script,
this patch makes sure the same flags are set when running the second
configuration.

Reported-by: Fabio Porcedda <fabio.porcedda@gmail.com>
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Cc: Fabio Porcedda <fabio.porcedda@gmail.com>
Cc: Luca Ceresoli <luca@lucaceresoli.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/cmake/cmake.mk

index d45c642095efd0b54051d14b53c1889a5d9ab2e1..235988b751e7debfd0914cdcc9fedcaa81028e0b 100644 (file)
@@ -14,7 +14,11 @@ define HOST_CMAKE_CONFIGURE_CMDS
        (cd $(@D); \
                LDFLAGS="$(HOST_LDFLAGS)" \
                CFLAGS="$(HOST_CFLAGS)" \
-               ./bootstrap --prefix=$(HOST_DIR)/usr --parallel=$(PARALLEL_JOBS) \
+               ./bootstrap --prefix=$(HOST_DIR)/usr \
+                       --parallel=$(PARALLEL_JOBS) -- \
+                       -DCMAKE_C_FLAGS="$(HOST_CFLAGS)" \
+                       -DCMAKE_CXX_FLAGS="$(HOST_CXXFLAGS)" \
+                       -DCMAKE_EXE_LINKER_FLAGS="$(HOST_LDFLAGS)" \
        )
 endef