dfu-util: new package
authorgregory hermant <gregory.hermant@calao-systems.com>
Fri, 20 Jul 2012 16:06:12 +0000 (18:06 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 20 Jul 2012 18:03:53 +0000 (20:03 +0200)
Signed-off-by: Gregory Hermant <gregory.hermant@calao-systems.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in.host
package/dfu-util/Config.in.host [new file with mode: 0644]
package/dfu-util/dfu-util.mk [new file with mode: 0644]

index 9fcfede00c36de523f201527350ac503df4bb51c..79050f25d9be0260d33716832a60e2d6c1129e1b 100644 (file)
@@ -1,5 +1,6 @@
 menu "Host utilities"
 
+source "package/dfu-util/Config.in.host"
 source "package/lpc3250loader/Config.in.host"
 source "package/omap-u-boot-utils/Config.in.host"
 source "package/openocd/Config.in.host"
diff --git a/package/dfu-util/Config.in.host b/package/dfu-util/Config.in.host
new file mode 100644 (file)
index 0000000..cfeebdc
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_HOST_DFU_UTIL
+       bool "host dfu-util"
+       help
+         Dfu-util is the host side implementation of the DFU 1.0 
+         specification of the USB forum. DFU is intended to download
+         and upload firmware to devices connected over USB. 
+
+         http://dfu-util.gnumonks.org/
diff --git a/package/dfu-util/dfu-util.mk b/package/dfu-util/dfu-util.mk
new file mode 100644 (file)
index 0000000..4ba7014
--- /dev/null
@@ -0,0 +1,13 @@
+#############################################################
+#
+# dfu-util
+#
+#############################################################
+DFU_UTIL_VERSION:=0.6
+DFU_UTIL_SOURCE = dfu-util-$(DFU_UTIL_VERSION).tar.gz
+DFU_UTIL_SITE = http://dfu-util.gnumonks.org/releases/
+
+HOST_DFU_UTIL_DEPENDENCIES = host-libusb
+
+$(eval $(host-autotools-package))
+