u-boot: remove extra CFLAGS / LDFLAGS handling
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 24 Apr 2011 21:26:00 +0000 (23:26 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 24 Apr 2011 21:26:00 +0000 (23:26 +0200)
TARGET_CONFIGURE_FLAGS already contain CFLAGS/LDFLAGS, so no point in
setting them explicitly.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
boot/u-boot/u-boot.mk

index a86819b5d882c27dfffd4a9b74d5d47143d41d5f..2f839c53c9f297e5f0d65f28f88690fe8dd0f278 100644 (file)
@@ -129,8 +129,6 @@ endif # BR2_TARGET_UBOOT_NETWORK
 # Build U-Boot itself
 $(U_BOOT_DIR)/$(U_BOOT_BIN): $(U_BOOT_DIR)/.header_modified
        $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               LDFLAGS="$(TARGET_LDFLAGS)" \
                $(U_BOOT_CONFIGURE_OPTS) \
                $(MAKE) CROSS_COMPILE="$(CCACHE) $(TARGET_CROSS)" ARCH=$(U_BOOT_ARCH) \
                $(U_BOOT_MAKE_OPT) -C $(U_BOOT_DIR)