package/gpsd: enable python support and modules
authorSergey Matyukevich <geomatsi@gmail.com>
Sun, 1 Nov 2020 11:47:12 +0000 (14:47 +0300)
committerYann E. MORIN <yann.morin.1998@free.fr>
Wed, 28 Jul 2021 19:24:52 +0000 (21:24 +0200)
Add option that enables gpsd python support including modules, tools,
and gpsfake test harness. If python is enabled then install python
modules unconditionally. Note that gpsd python modules run compatibly
under Python 2 and 3.x for x >= 2. So enable gpsd python support when
any Python version is enabled in board configuration. If no Python is
enabled, but gpsd Python support is requested, then select Python 3.

Signed-off-by: Sergey Matyukevich <geomatsi@gmail.com>
[yann.morin.1998@free.fr: fix check-package]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/gpsd/Config.in
package/gpsd/gpsd.mk

index 5dd57c34b8680d84333ce6f572414c79e8e7e227..1da9a5ce2abdc07570cef91ed5cadf61e9accada 100644 (file)
@@ -79,6 +79,17 @@ config BR2_PACKAGE_GPSD_MAX_DEV_VALUE
 config BR2_PACKAGE_GPSD_SQUELCH
        bool "squelch gpsd_report and gpsd_hexdump to save cpu"
 
+config BR2_PACKAGE_GPSD_PYTHON
+       bool "build Python support and modules"
+       depends on BR2_USE_WCHAR # python
+       select BR2_PACKAGE_PYTHON3 if !BR2_PACKAGE_PYTHON
+       help
+         Python libraries and tools for the gpsd service daemon
+         including gpsfake test harness.
+
+comment "GPSD python support not available with toolchain w/o wide characters support"
+       depends on !BR2_USE_WCHAR
+
 comment "Protocols"
 
 config BR2_PACKAGE_GPSD_AIVDM
index 41dff2f1555000a0e0fff2983ccf7e1700828915..0fbb5dfa1d59c9fc740a94194593a4771dc30351 100644 (file)
@@ -25,7 +25,6 @@ GPSD_SCONS_OPTS = \
        prefix=/usr \
        sysroot=$(STAGING_DIR) \
        strip=no \
-       python=no \
        qt=no \
        systemd=$(if $(BR2_INIT_SYSTEMD),yes,no)
 
@@ -189,6 +188,18 @@ ifeq ($(BR2_PACKAGE_GPSD_MAX_DEV),y)
 GPSD_SCONS_OPTS += max_devices=$(BR2_PACKAGE_GPSD_MAX_DEV_VALUE)
 endif
 
+ifeq ($(BR2_PACKAGE_PYTHON3),y)
+GPSD_SCONS_OPTS += \
+       python=yes \
+       python_libdir="/usr/lib/python$(PYTHON3_VERSION_MAJOR)/site-packages"
+else ifeq ($(BR2_PACKAGE_PYTHON),y)
+GPSD_SCONS_OPTS += \
+       python=yes \
+       python_libdir="/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages"
+else
+GPSD_SCONS_OPTS += python=no
+endif
+
 GPSD_SCONS_ENV += \
        LDFLAGS="$(GPSD_LDFLAGS)" \
        CFLAGS="$(GPSD_CFLAGS)" \