uboot: support -r option for mkenvimage
authorSimon Dawson <spdawson@gmail.com>
Mon, 9 Dec 2013 17:51:13 +0000 (17:51 +0000)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 12 Dec 2013 22:20:35 +0000 (23:20 +0100)
Some boards are configured in u-boot to store multiple redundant copies of
the environment image in flash.  For these boards, it is required to pass
the -r flag, when generating a boot environment image using mkenvimage.

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
boot/uboot/Config.in
boot/uboot/uboot.mk

index 77553c13bdc19ab2e6872b01721352a64c9fe6ed..d693bcfcdd40a79d335c28b68514752f1253c597 100644 (file)
@@ -251,6 +251,20 @@ config BR2_TARGET_UBOOT_ENVIMAGE_SIZE
          Size of envronment, can be prefixed with 0x for hexadecimal
          values.
 
+config BR2_TARGET_UBOOT_ENVIMAGE_REDUNDANT
+       bool "Environment has two copies"
+       help
+         Some platforms define in their U-Boot configuration that the
+         U-Boot environment should be duplicated in two locations (for
+         extra safety). Check your U-Boot configuration for the
+         CONFIG_ENV_ADDR_REDUND and CONFIG_ENV_SIZE_REDUND settings to
+         see if this is the case for your platform.
+
+         If it is the case, then you should enable this option to
+         ensure that the U-Boot environment image generated by
+         Buildroot is compatible with the "redundant environment"
+         mechanism of U-Boot.
+
 endif # BR2_TARGET_UBOOT_ENVIMAGE
 
 endif # BR2_TARGET_UBOOT
index 06b75eddeb214c7a8dec653f9274601567572b1c..ba7087e26f8d75ef1dc281ee43d1377750c62592 100644 (file)
@@ -120,6 +120,7 @@ define UBOOT_INSTALL_IMAGES_CMDS
                cp -dpf $(@D)/$(BR2_TARGET_UBOOT_SPL_NAME) $(BINARIES_DIR)/)
        $(if $(BR2_TARGET_UBOOT_ENVIMAGE),
                $(HOST_DIR)/usr/bin/mkenvimage -s $(BR2_TARGET_UBOOT_ENVIMAGE_SIZE) \
+               $(if $(BR2_TARGET_UBOOT_ENVIMAGE_REDUNDANT),-r) \
                -o $(BINARIES_DIR)/uboot-env.bin $(BR2_TARGET_UBOOT_ENVIMAGE_SOURCE))
 endef