imx-kobs: bump version to 5.4
authorAndrew Webster <awebster@arcx.com>
Fri, 10 Jun 2016 18:14:41 +0000 (14:14 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 15 Jun 2016 20:48:40 +0000 (22:48 +0200)
Changelog:
- Check raw mode flag for backward compatbility
- Fix membership name in bch geometry structure.
- Fix the previous implementation that may ruin the BBM
- Adapt raw page accesses to match the new raw_read/write implementation

The old raw access implementation (in GPMI driver) was considering that
data and OOB data were separated in their respective regions (the data
area and the OOB area of the page), which is not true.
They are actually interleaved this way:

METADATA + ((DATA + ECCBYTES) * N)

The new raw access implementation (in the GPMI driver) is hiding this
weird
layout to MTD users by exposing a more common layout:

DATA + METADATA + (N * ECCBYTES)

Here METADATA + (N * ECCBYTES) are exposed as if they were stored in the
OOB area.

Unfortunately kobs-ng rely on this weird layout when accessing the NAND
in raw mode.

This patch is based on the Yocto equivalent:
https://github.com/Freescale/meta-fsl-arm/commit/a7545b1

Signed-off-by: Andrew Webster <awebster@arcx.com>
Reviewed-by: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/freescale-imx/imx-kobs/imx-kobs.hash
package/freescale-imx/imx-kobs/imx-kobs.mk

index 09d42edadcb9632d17f992354a7a4956ab3917ed..b942bd35a0c9d3d2f036942fa8d98c13e954c90d 100644 (file)
@@ -1,2 +1 @@
-# locally computed
-sha256 45f729fc2b49556f1ca9df778f52bf5cc749cfe53664c8206daab29991c5f6c1  imx-kobs-5.3.tar.gz
+sha256 85171b46068ac47c42fedb8104167bf9afd33dd9527ed127e1ca2eb29d7a86bf  imx-kobs-5.4.tar.gz
index cc4721f7d146c6a10aa4924dabd398f09bbcb702..b80d5bdef0784739a2731679dc0386ec901d46f7 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-IMX_KOBS_VERSION = 5.3
+IMX_KOBS_VERSION = 5.4
 IMX_KOBS_SITE = $(FREESCALE_IMX_SITE)
 IMX_KOBS_LICENSE = GPLv2+
 IMX_KOBS_LICENSE_FILES = COPYING