package/go: security bump to version 1.13.7
authorPeter Korsgaard <peter@korsgaard.com>
Tue, 28 Jan 2020 22:37:43 +0000 (23:37 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 29 Jan 2020 19:47:32 +0000 (20:47 +0100)
Fixes the following security issue:

- Panic in crypto/x509 certificate parsing and golang.org/x/crypto/cryptobyte

On 32-bit architectures, a malformed input to crypto/x509 or the ASN.1
parsing functions of golang.org/x/crypto/cryptobyte can lead to a panic.
The malformed certificate can be delivered via a crypto/tls connection to a
client, or to a server that accepts client certificates.  net/http clients
can be made to crash by an HTTPS server, while net/http servers that accept
client certificates will recover the panic and are unaffected.  Thanks to
Project Wycheproof for providing the test cases that led to the discovery of
this issue.  The issue is CVE-2020-7919 and Go issue golang.org/issue/36837.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/go/go.hash
package/go/go.mk

index f440490b4eeddaf4ec62f0db13307295893371ab..b607ce37d4546cdafc90d2b17e552ddb4295b418 100644 (file)
@@ -1,3 +1,3 @@
 # From https://golang.org/dl/
-sha256 aae5be954bdc40bcf8006eb77e8d8a5dde412722bc8effcdaf9772620d06420c  go1.13.6.src.tar.gz
+sha256 e4ad42cc5f5c19521fbbbde3680995f2546110b5c6aa2b48c3754ff7af9b41f4  go1.13.7.src.tar.gz
 sha256 2d36597f7117c38b006835ae7f537487207d8ec407aa9d9980794b2030cbc067  LICENSE
index a0f796c21b8af59870a80e009084ed5d75957625..43c04ac0c5fea5b9abaa14af74216ad8476a87c5 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-GO_VERSION = 1.13.6
+GO_VERSION = 1.13.7
 GO_SITE = https://storage.googleapis.com/golang
 GO_SOURCE = go$(GO_VERSION).src.tar.gz