package/most: new package
authorSven Oliver Moll <buildroot@svol.li>
Sat, 13 Apr 2019 20:40:57 +0000 (22:40 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 13 Apr 2019 21:54:42 +0000 (23:54 +0200)
--with-slang has to be given explicitly, otherwise the configure script
looks for slang.h in host directories.

Signed-off-by: Sven Oliver Moll <svolli@svolli.de>
[Arnout: add --with-slang config option]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
DEVELOPERS
package/Config.in
package/most/Config.in [new file with mode: 0644]
package/most/most.hash [new file with mode: 0644]
package/most/most.mk [new file with mode: 0644]

index 40d0642c2e64a7f8bc8695e0522f34baa6f04901..a77a7306033f654d78528205a42456fae903806f 100644 (file)
@@ -2113,6 +2113,9 @@ F:        package/libmms/
 F:     package/orc/
 F:     package/wampcc/
 
+N:     Sven Oliver Moll <svolli@svolli.de>
+F:     package/most/
+
 N:     Theo Debrouwere <t.debrouwere@televic.com>
 F:     package/pugixml/
 
index ceb78fac0b0d8363d2f68598584fc1aae9d70839..158a030e53f51bca06cd952fca8332b0668273a1 100644 (file)
@@ -2231,6 +2231,7 @@ menu "Text editors and viewers"
        source "package/joe/Config.in"
        source "package/less/Config.in"
        source "package/mc/Config.in"
+       source "package/most/Config.in"
        source "package/nano/Config.in"
        source "package/uemacs/Config.in"
        source "package/vim/Config.in"
diff --git a/package/most/Config.in b/package/most/Config.in
new file mode 100644 (file)
index 0000000..943042c
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_MOST
+       bool "most"
+       depends on BR2_USE_MMU # slang
+       select BR2_PACKAGE_SLANG
+       help
+         most is a powerful pager, including features like multi
+         document support, hex view and unpack on-the-fly.
+
+         https://www.jedsoft.com/most/
+
+         Note: this program depends on the slang library which is
+         rather large to be used just for this pager.
diff --git a/package/most/most.hash b/package/most/most.hash
new file mode 100644 (file)
index 0000000..151caad
--- /dev/null
@@ -0,0 +1,6 @@
+# From https://www.jedsoft.org/releases/most/
+sha1 db811669a6b22c15478c957b439b5e4483ce1c95 most-5.1.0.tar.gz
+# Locally computed
+sha256 db805d1ffad3e85890802061ac8c90e3c89e25afb184a794e03715a3ed190501  most-5.1.0.tar.gz
+sha256 1b2a567f289f66a143c56353e7b3d4fa5862514a5e3c5cfdf8b02ee5e5aaa953  COPYING
+sha256 47ad1c3f9b94d6ec42d9bee6c5df980c5c2daa5b9d22113545ae6a3f21ca2f52  COPYRIGHT
diff --git a/package/most/most.mk b/package/most/most.mk
new file mode 100644 (file)
index 0000000..d24e67f
--- /dev/null
@@ -0,0 +1,24 @@
+################################################################################
+#
+# most
+#
+################################################################################
+
+MOST_SITE = http://www.jedsoft.org/releases/most
+MOST_VERSION = 5.1.0
+MOST_LICENSE = GPL-2.0+
+MOST_LICENSE_FILES = COPYING COPYRIGHT
+MOST_DEPENDENCIES = slang
+
+MOST_CONF_OPTS = --with-slang=$(STAGING_DIR)/usr
+
+define MOST_REMOVE_LOCAL_SLANG_CHECK
+       $(SED) 's/ slangversion / /g' $(@D)/src/Makefile.in
+endef
+MOST_POST_PATCH_HOOKS += MOST_REMOVE_LOCAL_SLANG_CHECK
+
+define MOST_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/src/objs/most $(TARGET_DIR)/usr/bin/most
+endef
+
+$(eval $(autotools-package))