Makefile: split off 'list-defconfigs' from 'help'
authorArnout Vandecappelle <arnout@mind.be>
Sat, 21 Mar 2015 19:49:46 +0000 (20:49 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 4 Apr 2015 13:13:52 +0000 (15:13 +0200)
As discussed in the FOSDEM2015 BR developer meeting, the output of
'make help' is too long for comfortable reading. To shorten it, split
off the list of defconfigs in a new target, 'list-defconfigs'.

Declare the new target as phony.

Add 'list-defconfigs' to the documentation.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile
docs/manual/customize-outside-br.txt
docs/manual/make-tips.txt

index 397effed71dd3a852379560cb8e30d7a045b9233..32a18ff4d936f881de7f5bb82d71f6fbff5902ae 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -435,7 +435,7 @@ world: target-post-image
 
 .PHONY: all world toolchain dirs clean distclean source outputmakefile \
        legal-info legal-info-prepare legal-info-clean printvars help \
-       target-finalize target-post-image \
+       list-defconfigs target-finalize target-post-image \
        $(TARGETS) $(TARGETS_ROOTFS) \
        $(TARGETS_DIRCLEAN) $(TARGETS_SOURCE) $(TARGETS_LEGAL_INFO) \
        $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) \
@@ -907,6 +907,11 @@ endif
        @echo '  make V=0|1             - 0 => quiet build (default), 1 => verbose build'
        @echo '  make O=dir             - Locate all output files in "dir", including .config'
        @echo
+       @echo 'For further details, see README, generate the Buildroot manual, or consult'
+       @echo 'it on-line at http://buildroot.org/docs.html'
+       @echo
+
+list-defconfigs:
        @echo 'Built-in configs:'
        @$(foreach b, $(sort $(notdir $(wildcard $(TOPDIR)/configs/*_defconfig))), \
          printf "  %-35s - Build for %s\\n" $(b) $(b:_defconfig=);)
@@ -917,9 +922,6 @@ ifneq ($(wildcard $(BR2_EXTERNAL)/configs/*_defconfig),)
          printf "  %-35s - Build for %s\\n" $(b) $(b:_defconfig=);)
 endif
        @echo
-       @echo 'For further details, see README, generate the Buildroot manual, or consult'
-       @echo 'it on-line at http://buildroot.org/docs.html'
-       @echo
 
 release: OUT = buildroot-$(BR2_VERSION)
 
index 5d63e60bdf26137e10a63891fce0ed8d8722b962..aac9a4313d259d5b698eefbca0c61f2249bc36b1 100644 (file)
@@ -100,6 +100,6 @@ And then in +$(BR2_EXTERNAL)/package/package1+ and
 
  * One can store Buildroot defconfigs in the +configs+ subdirectory of
    +$(BR2_EXTERNAL)+. Buildroot will automatically show them in the
-   output of +make help+ and allow them to be loaded with the normal
-   +make <name>_defconfig+ command. They will be visible under the
-   +User-provided configs+' label in the 'make help' output.
+   output of +make list-defconfigs+ and allow them to be loaded with the
+   normal +make <name>_defconfig+ command. They will be visible under the
+   +User-provided configs+' label in the 'make list-defconfigs' output.
index 027eddf83c4ae1fe202bd4ded9ea9c972d989d9a..1cf15448d389e96a7de121f801e0c85504f942d8 100644 (file)
@@ -12,6 +12,12 @@ This is a collection of tips that help you make the most of Buildroot.
  $ make V=1 <target>
 --------------------
 
+.Display the list of boards with a defconfig:
+
+--------------------
+ $ make list-defconfigs
+--------------------
+
 .Display all available targets:
 
 --------------------