package/python-pybind: new package
authorGuillaume W. Bres <guillaume.bressaix@gmail.com>
Mon, 8 Jun 2020 21:30:43 +0000 (23:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 10 Jun 2020 20:53:09 +0000 (22:53 +0200)
PyBind is a light (headers only) package for C++/Python and Python/C++
bindings.

Signed-off-by: Guillaume W. Bres <guillaume.bressaix@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-pybind/Config.in [new file with mode: 0644]
package/python-pybind/python-pybind.hash [new file with mode: 0644]
package/python-pybind/python-pybind.mk [new file with mode: 0644]

index f697c96ce4859b3733a4130d44e7d201a2bb2c1f..9a9430708210e7eb92394fc2520a2597aa26bd0b 100644 (file)
@@ -1052,6 +1052,7 @@ F:        package/sdl2/
 N:     Guillaume William Brs <guillaume.bressaix@gmail.com>
 F:     package/liquid-dsp/
 F:     package/pixiewps/
+F:     package/python-pybind/
 F:     package/reaver/
 
 N:     Guo Ren <ren_guo@c-sky.com>
index 520e5d5570e0b44b15031c58035c3387c1f6ad73..b0a7da2f5c9b387b99291a5338d7d932213a533f 100644 (file)
@@ -1070,6 +1070,7 @@ menu "External python modules"
        source "package/python-pyalsa/Config.in"
        source "package/python-pyasn1/Config.in"
        source "package/python-pyasn1-modules/Config.in"
+       source "package/python-pybind/Config.in"
        source "package/python-pycairo/Config.in"
        source "package/python-pycares/Config.in"
        source "package/python-pycli/Config.in"
diff --git a/package/python-pybind/Config.in b/package/python-pybind/Config.in
new file mode 100644 (file)
index 0000000..604cb9e
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PYTHON_PYBIND
+       bool "python-pybind"
+       help
+         PyBind is a lightweight header-only library that exposes C++
+         types in Python and vice versa, mainly to create Python
+         bindings of existing C++ code.
+
+         http://pybind11.readthedocs.org/en/master
diff --git a/package/python-pybind/python-pybind.hash b/package/python-pybind/python-pybind.hash
new file mode 100644 (file)
index 0000000..751b0bd
--- /dev/null
@@ -0,0 +1,4 @@
+# Locally calculated
+sha256  97504db65640570f32d3fdf701c25a340c8643037c3b69aec469c10c93dc8504   python-pybind-2.5.0.tar.gz
+# License files, locally calculated
+sha256  9a37ea54aa3cf12c7f3292799f20822ffd4b9b7142b36a7a9997b28c39264dc9   LICENSE
diff --git a/package/python-pybind/python-pybind.mk b/package/python-pybind/python-pybind.mk
new file mode 100644 (file)
index 0000000..634e869
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# python-pybind
+#
+################################################################################
+
+PYTHON_PYBIND_VERSION = 2.5.0
+PYTHON_PYBIND_SITE = $(call github,pybind,pybind11,v$(PYTHON_PYBIND_VERSION))
+PYTHON_PYBIND_LICENSE = BSD-3-Clause
+PYTHON_PYBIND_LICENSE_FILES = LICENSE
+PYTHON_PYBIND_SETUP_TYPE = setuptools
+
+$(eval $(python-package))