target-gcc: fix build
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 27 Jul 2010 16:17:26 +0000 (18:17 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 27 Jul 2010 16:23:16 +0000 (18:23 +0200)
Now that $(STAGING_DIR)/usr/bin is no longer in the PATH, we need to
pass the absolute paths to $(TARGET_CC) when building the target gcc
compiler.

This commit fixes the target gcc build problem reported on the list. I
have successfully been able to build a target gcc for ARM, use it to
compile a hello world application on the target and run this
application.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/gcc/gcc-uclibc-4.x.mk

index cfbe6164d3a04b03fca5b201fd92dc363df823c4..52b20e95916d16a0f04bdb122321a14bbf81cf4c 100644 (file)
@@ -397,6 +397,8 @@ $(GCC_BUILD_DIR3)/.configured: $(GCC_BUILD_DIR3)/.prepared
                CXXFLAGS_FOR_TARGET="$(TARGET_CFLAGS) $(TARGET_SOFT_FLOAT)" \
                CFLAGS="$(TARGET_CFLAGS) $(TARGET_SOFT_FLOAT)" \
                BOOT_CFLAGS="$(TARGET_CFLAGS) $(TARGET_SOFT_FLOAT)" \
+               GCC_FOR_TARGET="$(TARGET_CC)" \
+               CC_FOR_TARGET="$(TARGET_CC)" \
                $(GCC_SRC_DIR)/configure $(QUIET) \
                --prefix=/usr \
                --build=$(GNU_HOST_NAME) \