swfdec: fix build when no libglib2-dev package is installed on host
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 26 Jul 2010 09:10:03 +0000 (11:10 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 26 Jul 2010 09:10:03 +0000 (11:10 +0200)
Make sure it uses the libglib2-host binaries we are building.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/multimedia/swfdec/swfdec.mk

diff --git a/CHANGES b/CHANGES
index 2b3a07158c5f1d567519f370a0218c250d96594b..64a60b363543967e9fbac05fc0373fa49cfc9054 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -24,7 +24,7 @@
        linux-fusion, lmbench, lrzsz, ltrace, make, module-init-tools,
        mplayer, mysql_client, nbd, ncurses, neon, netcat, netperf,
        ntfsprogs, openssl, php, qt, quagga, sqlite, sdl, sdl_mixer,
-       sdl_sound, sdl_ttf, squashfs, thttpd, tn5250, tremor,
+       sdl_sound, sdl_ttf, squashfs, swfdec, thttpd, tn5250, tremor,
        usbutils, webif, xkeyboard-config, xserver_xorg-server, xvkbd
 
        Removed packages: modutils, portage, rxvt
index d55568f56aa2bd572eba0e9abf6382331a01716b..58bfd1576d064ae58e154335af094813cede1c19 100644 (file)
@@ -8,6 +8,9 @@ SWFDEC_VERSION_MINOR = 4
 SWFDEC_VERSION = $(SWFDEC_VERSION_MAJOR).$(SWFDEC_VERSION_MINOR)
 SWFDEC_SOURCE = swfdec-$(SWFDEC_VERSION).tar.gz
 SWFDEC_SITE = http://swfdec.freedesktop.org/download/swfdec/$(SWFDEC_VERSION_MAJOR)
+SWFDEC_MAKE_OPT = \
+       GLIB_MKENUMS=$(HOST_DIR)/usr/bin/glib-mkenums \
+       GLIB_GENMARSHAL=$(HOST_DIR)/usr/bin/glib-genmarshal
 
 SWFDEC_LIBTOOL_PATCH = NO
 SWFDEC_INSTALL_STAGING = YES
@@ -28,3 +31,8 @@ SWFDEC_CONF_OPT += --disable-gtk
 endif
 
 $(eval $(call AUTOTARGETS,package/multimedia,swfdec))
+
+# swfdec uses glib-* at install time
+# Notice: must come after AUTOTARGETS as that's where these variables gets set
+SWFDEC_INSTALL_TARGET_OPT += $(SWFDEC_MAKE_OPT)
+SWFDEC_INSTALL_STAGING_OPT += $(SWFDEC_MAKE_OPT)