make sure we depend on fakeroot existing #366 by pnoffke
authorMike Frysinger <vapier@gentoo.org>
Mon, 8 Aug 2005 00:41:40 +0000 (00:41 -0000)
committerMike Frysinger <vapier@gentoo.org>
Mon, 8 Aug 2005 00:41:40 +0000 (00:41 -0000)
target/jffs2/jffs2root.mk

index 04922aaf2fa39407ebe01e59ce78863ff87ef0fe..302311e462598ca1dbdc9a9312c74fb63a2485df 100644 (file)
@@ -38,12 +38,14 @@ JFFS2_TARGET := $(subst ",,$(BR2_TARGET_ROOTFS_JFFS2_OUTPUT))
 # value of MKFS_JFFS2 to either the previously installed copy or the one
 # just built.
 #
-$(JFFS2_TARGET): mtd-host
+$(JFFS2_TARGET): host-fakeroot mtd-host
        -@find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIP) 2>/dev/null || true;
        @rm -rf $(TARGET_DIR)/usr/man
        @rm -rf $(TARGET_DIR)/usr/share/man
        @rm -rf $(TARGET_DIR)/usr/info
-       /sbin/ldconfig -r $(TARGET_DIR)
+       test -e "$(TARGET_DIR)/etc/ld.so.conf" \
+               && /sbin/ldconfig -r $(TARGET_DIR) \
+               || true
        # Use fakeroot to pretend all target binaries are owned by root
        $(STAGING_DIR)/usr/bin/fakeroot \
                -i $(STAGING_DIR)/fakeroot.env \