xserver_xorg-server: Xvfb support
authorIsmael Luceno <ismael.luceno@gmail.com>
Tue, 10 Apr 2012 08:24:07 +0000 (08:24 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 22 Sep 2012 11:48:10 +0000 (13:48 +0200)
Signed-off-by: Ismael Luceno <ismael.luceno@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/x11r7/xserver_xorg-server/Config.in
package/x11r7/xserver_xorg-server/xserver_xorg-server.mk

index ddc03c6aeb417f569bbd366ded216ac3507d8c0d..4e284a0cb9d406fa093ad1db87199c348f9931f1 100644 (file)
@@ -56,14 +56,23 @@ config BR2_PACKAGE_XSERVER_XORG_SERVER
 comment "xorg-xserver is BROKEN on AVR32"
        depends on BR2_avr32
 
+if BR2_PACKAGE_XSERVER_XORG_SERVER
+
 config BR2_PACKAGE_XSERVER_XORG_SERVER_NULL_CURSOR
     bool "Null root cursor"
-    depends on BR2_PACKAGE_XSERVER_XORG_SERVER
     help
         Don't display root cursor.
 
 config BR2_PACKAGE_XSERVER_XORG_SERVER_AIGLX
     bool "Enable AIGLX Extension"
-    depends on BR2_PACKAGE_XSERVER_XORG_SERVER
     help
         Enable/Use AIGLX extension.
+
+comment "Optional Servers"
+
+config BR2_PACKAGE_XSERVER_XORG_SERVER_XVFB
+    bool "Xvfb server"
+    help
+        Virtual frame buffer X server.
+
+endif
index 5913f7987bc61dd5dd72e8052a0ae57abf1bab59..9b2d9aeef404e853294fc9a262cd034e02355ab7 100644 (file)
@@ -58,11 +58,11 @@ XSERVER_XORG_SERVER_DEPENDENCIES =  \
        host-pkg-config
 
 XSERVER_XORG_SERVER_CONF_OPT = --disable-config-hal \
-               --disable-xnest --disable-xephyr --disable-xvfb \
-               --disable-dmx \
+               --disable-xnest --disable-xephyr --disable-dmx \
                --with-builder-addr=buildroot@uclibc.org \
                CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/pixman-1" \
-               --with-fontdir=/usr/share/fonts/X11/ --localstatedir=/var
+               --with-fontdir=/usr/share/fonts/X11/ --localstatedir=/var \
+               --$(if $(BR2_PACKAGE_XSERVER_XORG_SERVER_XVFB),en,dis)able-xvfb
 
 ifeq ($(BR2_PACKAGE_XSERVER_xorg),y)
 XSERVER_XORG_SERVER_CONF_OPT += --enable-xorg