package/libvirt: disable stack-protector
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 7 Aug 2021 17:23:59 +0000 (19:23 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 7 Aug 2021 21:19:51 +0000 (23:19 +0200)
Set warning_level to 1 instead of the default value of 2 to disable
stack-protector and avoid the following build failure since the addition
of the package in commit ccfc90e1010e42e6529afae3a5ea8bf7226dabc1:

/tmp/instance-5/output-1/host/opt/ext-toolchain/bin/../lib/gcc/i686-buildroot-linux-uclibc/9.3.0/../../../../i686-buildroot-linux-uclibc/bin/ld: tests/commandhelper.p/commandhelper.c.o: in function `printInput':
commandhelper.c:(.text+0xad): undefined reference to `__stack_chk_guard'

Fixes:
 - http://autobuild.buildroot.org/results/a2657eb18b579752c8217ab356adcb52931f6785

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr:
  - move to a separate assignment
  - add a big fat comment to explain it
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libvirt/libvirt.mk

index a0fd5af951777947d78f61d0cfb32647c97294ae..cd037a6b0274344b326513f498d16c410f34637e 100644 (file)
@@ -53,6 +53,13 @@ LIBVIRT_CONF_OPTS = \
        -Dudev=enabled \
        -Dwireshark_dissector=disabled
 
+# warning_level should only drive the level of warnings during the
+# compilation of C code. However, libvirt misuses that to also
+# enable SSP when warning_level == 2
+# Force warning_level=1 to disable SSP, and let our toolchain wrapper
+# handle it.
+LIBVIRT_CONF_OPTS += -Dwarning_level=1
+
 ifeq ($(BR2_PACKAGE_ATTR),y)
 LIBVIRT_CONF_OPTS += -Dattr=enabled
 LIBVIRT_DEPENDENCIES += attr