dbus: depend on libxml2-install-staging instead for libxml2
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 20 Jun 2008 21:45:21 +0000 (21:45 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 20 Jun 2008 21:45:21 +0000 (21:45 -0000)
Makefile.autools.in doesn't have proper dependencies set up for
the .stamp files, so use the libxml2-install-staging target instead.
This does unfortunately mean that dbus is always considered out of
date, but atleast it works.

package/dbus/dbus.mk

index d68f4341419ce56cc18c52ac2cbe8ea0e4a3d3b3..cfa4e7feba10f5b0681e54855848955af31036a5 100644 (file)
@@ -18,12 +18,9 @@ DBUS_XML:=expat
 DBUS_XML_DEP:=$(STAGING_DIR)/usr/lib/libexpat.so.1
 else
 DBUS_XML:=libxml
-# depend on the exact target instead of libxml2 so dbus isn't always
-# considered out-of-date.
-# It would be neat to use $(LIBXML2_TARGET_INSTALL_STAGING) here,
-# but the libxml2 makefile is only parsed after dbus, so that doesn't work
-DBUS_XML_DEP:=$(BUILD_DIR)/libxml2-2.6.29/.stamp_staging_installed
-$(LIBXML2_TARGET_INSTALL_STAGING)
+# Makefile.autotools.in unfortunately has broken dependency handling,
+# so we cannot do the same for libxml2
+DBUS_XML_DEP:=libxml2-install-staging
 endif
 
 $(DL_DIR)/$(DBUS_SOURCE):