package/pkg-meson.mk avoid host ccache detection
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 10 Jan 2021 11:19:21 +0000 (12:19 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Thu, 21 Jan 2021 21:11:46 +0000 (22:11 +0100)
meson will by default try to detect the presence of ccache, and if
found, will use it unconditionally.

However, using a system-wide ccache, which would be using our own cache
directory, may very well conflict with our own ccache.

But there is no option to disable that meson behaviour. The only
workaround that is even the official documented way to do so, is to
actually pass environment variables that point to the compiler:

    https://mesonbuild.com/Feature-autodetection.html#ccache

For the host variants, we pass $(HOST_CONFIGURE_OPTS) in the environment,
and this contains correct settings for CC and CXX, so meson does not try
and detect ccache; it uses exactly what we tell it to use.

For the target variant, the settings for the cross-compiler are defined
in the cross-compilation file, and so meson just abides by our will. But
for the compiler-for-build, there is no way to specify the CC_FOR_BUILD
or CXX_FOR_BUILD via a cross-compilation file:

    https://mesonbuild.com/Machine-files.html
    https://mesonbuild.com/Cross-compilation.html

We could pass the full TARGET_CONFIGURE_OPTS in the environment, like we
do for the host variant, but this contains a lot more variables that are
supposed to be covered by the cross-compilation file.

So, we stay safe and just provide the exact two variables that meson
will use to avoid detecting ccache.

If the current configuration defines the use of ccache, then these two
variables will be properly setup to use our own ccache.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Gleb Mazovetskiy <glex.spb@gmail.com>
Cc: James Hilliard <james.hilliard1@gmail.com>
Cc: Norbert Lange <nolange79@gmail.com>
package/pkg-meson.mk

index e0b843dc3c392ae2077cc69ddcfac63623288a71..de0e6e8ea3f86872179a705986809fb299b13fca 100644 (file)
@@ -81,7 +81,11 @@ define $(2)_CONFIGURE_CMDS
            -e "/^\[properties\]$$$$/s:$$$$:$$(foreach x,$$($(2)_MESON_EXTRA_PROPERTIES),\n$$(x)):" \
            package/meson/cross-compilation.conf.in \
            > $$($$(PKG)_SRCDIR)/build/cross-compilation.conf
-       PATH=$$(BR_PATH) $$($$(PKG)_CONF_ENV) $$(MESON) \
+       PATH=$$(BR_PATH) \
+       CC_FOR_BUILD="$(HOSTCC)" \
+       CXX_FOR_BUILD="$(HOSTCC)" \
+       $$($$(PKG)_CONF_ENV) \
+       $$(MESON) \
                --prefix=/usr \
                --libdir=lib \
                --default-library=$(if $(BR2_STATIC_LIBS),static,shared) \