skeleton: Rename skeleton-none to skeleton-init-none
authorCam Hutchison <camh@xdna.net>
Sun, 13 Aug 2017 21:21:09 +0000 (07:21 +1000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 14 Aug 2017 19:52:43 +0000 (21:52 +0200)
The skeletons are based on the selection of BR2_INIT_*, so add init- to
the package name to make this clearer. The name skeleton-none implies no
skeleton at all, not a base skeleton with no init-specific files.

Signed-off-by: Cam Hutchison <camh@xdna.net>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/skeleton-init-none/Config.in [new file with mode: 0644]
package/skeleton-init-none/skeleton-init-none.mk [new file with mode: 0644]
package/skeleton-none/Config.in [deleted file]
package/skeleton-none/skeleton-none.mk [deleted file]
system/Config.in

index b5170b044c7747827841ef20324edd873f6eab33..b48eac65cab6134ce16a03669ab242ddba7d2784 100644 (file)
@@ -4,7 +4,7 @@ menu "Target packages"
        source "package/skeleton/Config.in"
        source "package/skeleton-common/Config.in"
        source "package/skeleton-custom/Config.in"
-       source "package/skeleton-none/Config.in"
+       source "package/skeleton-init-none/Config.in"
        source "package/skeleton-systemd/Config.in"
        source "package/skeleton-sysv/Config.in"
 
diff --git a/package/skeleton-init-none/Config.in b/package/skeleton-init-none/Config.in
new file mode 100644 (file)
index 0000000..426954c
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_SKELETON_INIT_NONE
+       bool
+       select BR2_PACKAGE_HAS_SKELETON
+       select BR2_PACKAGE_SKELETON_COMMON
+
+config BR2_PACKAGE_PROVIDES_SKELETON
+       default "skeleton-init-none" if BR2_PACKAGE_SKELETON_INIT_NONE
diff --git a/package/skeleton-init-none/skeleton-init-none.mk b/package/skeleton-init-none/skeleton-init-none.mk
new file mode 100644 (file)
index 0000000..04e38c9
--- /dev/null
@@ -0,0 +1,18 @@
+################################################################################
+#
+# skeleton-init-none
+#
+################################################################################
+
+# The skeleton can't depend on the toolchain, since all packages depends on the
+# skeleton and the toolchain is a target package, as is skeleton.
+# Hence, skeleton would depends on the toolchain and the toolchain would depend
+# on skeleton.
+SKELETON_INIT_NONE_ADD_TOOLCHAIN_DEPENDENCY = NO
+SKELETON_INIT_NONE_ADD_SKELETON_DEPENDENCY = NO
+
+SKELETON_INIT_NONE_DEPENDENCIES = skeleton-common
+
+SKELETON_INIT_NONE_PROVIDES = skeleton
+
+$(eval $(generic-package))
diff --git a/package/skeleton-none/Config.in b/package/skeleton-none/Config.in
deleted file mode 100644 (file)
index 43fb3f2..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-config BR2_PACKAGE_SKELETON_NONE
-       bool
-       select BR2_PACKAGE_HAS_SKELETON
-       select BR2_PACKAGE_SKELETON_COMMON
-
-config BR2_PACKAGE_PROVIDES_SKELETON
-       default "skeleton-none" if BR2_PACKAGE_SKELETON_NONE
diff --git a/package/skeleton-none/skeleton-none.mk b/package/skeleton-none/skeleton-none.mk
deleted file mode 100644 (file)
index 9e95798..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-################################################################################
-#
-# skeleton-none
-#
-################################################################################
-
-# The skeleton can't depend on the toolchain, since all packages depends on the
-# skeleton and the toolchain is a target package, as is skeleton.
-# Hence, skeleton would depends on the toolchain and the toolchain would depend
-# on skeleton.
-SKELETON_NONE_ADD_TOOLCHAIN_DEPENDENCY = NO
-SKELETON_NONE_ADD_SKELETON_DEPENDENCY = NO
-
-SKELETON_NONE_DEPENDENCIES = skeleton-common
-
-SKELETON_NONE_PROVIDES = skeleton
-
-$(eval $(generic-package))
index 59d8eab271a06c2dce4b892cb8392bc553b9fae9..45326f09859af28184b8e7d6b38ad939c85f57a2 100644 (file)
@@ -12,7 +12,7 @@ config BR2_ROOTFS_SKELETON_DEFAULT
        select BR2_PACKAGE_SKELETON_SYSV if BR2_INIT_SYSV
        select BR2_PACKAGE_SKELETON_SYSV if BR2_INIT_BUSYBOX
        select BR2_PACKAGE_SKELETON_SYSTEMD if BR2_INIT_SYSTEMD
-       select BR2_PACKAGE_SKELETON_NONE if BR2_INIT_NONE
+       select BR2_PACKAGE_SKELETON_INIT_NONE if BR2_INIT_NONE
        help
          Use default target skeleton