package/usb_modeswitch: bump to version 2.6.0
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 22 Dec 2019 11:06:44 +0000 (12:06 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 22 Dec 2019 16:18:05 +0000 (17:18 +0100)
- Drop first patch (not needed anymore) and all jimtcl related
  workarounds as embedded jimtcl has been removed
- Parallel build issue has been fixed
- Update hash of COPYING as this file has been updated to reflect that
  dispatcher.c is under BSD-2-Clause

Full ChangeLog: http://www.draisberghof.de/usb_modeswitch/ChangeLog

Upstream provides an md5 of the tarball, so we add it (even though
that's a weak hash).

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr:
  - meld with the license fix patch
  - simplify license list
  - add md5 from upstream
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/usb_modeswitch/0001-Makefile-allow-extra-configure-flags-to-be-passed-to.patch [deleted file]
package/usb_modeswitch/Config.in
package/usb_modeswitch/usb_modeswitch.hash
package/usb_modeswitch/usb_modeswitch.mk

diff --git a/package/usb_modeswitch/0001-Makefile-allow-extra-configure-flags-to-be-passed-to.patch b/package/usb_modeswitch/0001-Makefile-allow-extra-configure-flags-to-be-passed-to.patch
deleted file mode 100644 (file)
index 9e1e681..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-From 1309df373c882f27f476130b06746a6d1e1a0f85 Mon Sep 17 00:00:00 2001
-From: Peter Korsgaard <peter@korsgaard.com>
-Date: Fri, 3 Nov 2017 23:21:44 +0100
-Subject: [PATCH] Makefile: allow extra configure flags to be passed to jimtcl
- on the make command line
-
-E.G. to pass --host / --build for cross compilation.
-
-Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
----
- Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Makefile b/Makefile
-index a151e2a..94dabd9 100644
---- a/Makefile
-+++ b/Makefile
-@@ -19,7 +19,7 @@ TCL        ?= $(HOST_TCL)
- else
- TCL        ?= /usr/bin/tclsh
- endif
--JIM_CONFIGURE_OPTS = --disable-lineedit \
-+override JIM_CONFIGURE_OPTS += --disable-lineedit \
-       --with-out-jim-ext="stdlib posix load signal syslog" --prefix=/usr
- .PHONY: clean install install-common uninstall \
--- 
-2.11.0
-
index f709a550c157b256e1c6ecc77c855abf101622d7..579761c040b015cc1916baf0cbcc8c71b02bc458 100644 (file)
@@ -1,6 +1,7 @@
 config BR2_PACKAGE_USB_MODESWITCH
        bool "usb_modeswitch"
        depends on BR2_TOOLCHAIN_HAS_THREADS # libusb
+       select BR2_PACKAGE_JIMTCL if !BR2_PACKAGE_TCL || BR2_PACKAGE_TCL_SHLIB_ONLY
        select BR2_PACKAGE_LIBUSB
        help
          Some USB devices such as 3G/4G broadband modems power-up
index 3cbd370e2cc7c431c388bc6c3f28a8a06269ad54..4cbd5dbea2d389a0d8b1543bc66d967d6e6eee8e 100644 (file)
@@ -1,3 +1,5 @@
+# From http://www.draisberghof.de/usb_modeswitch/
+md5     be73dcc84025794081a1d4d4e5a75e4c  usb-modeswitch-2.6.0.tar.bz2
 # Locally calculated
-sha256 abffac09c87eacd78e101545967dc25af7e989745b4276756d45dbf4008a2ea6  usb-modeswitch-2.5.2.tar.bz2
-sha256 32b1062f7da84967e7019d01ab805935caa7ab7321a7ced0e30ebe75e5df1670  COPYING
+sha256 c215236e6bada6e659fc195a31d611ea298a4bdb4d57a0d68c553b56585f8ba3  usb-modeswitch-2.6.0.tar.bz2
+sha256 6195429209313925c0eba6c0da4ee7a6cb4277b99e35c886913f80f91ec20b94  COPYING
index 9832d3c808d4f7ec72a0457d12185f6ff62b25a7..7e9ed422b606fbf190a82c7284124e5d2a6b7def 100644 (file)
@@ -4,35 +4,30 @@
 #
 ################################################################################
 
-USB_MODESWITCH_VERSION = 2.5.2
+USB_MODESWITCH_VERSION = 2.6.0
 USB_MODESWITCH_SOURCE = usb-modeswitch-$(USB_MODESWITCH_VERSION).tar.bz2
 USB_MODESWITCH_SITE = http://www.draisberghof.de/usb_modeswitch
 USB_MODESWITCH_DEPENDENCIES = libusb
-USB_MODESWITCH_LICENSE = GPL-2.0+
+USB_MODESWITCH_LICENSE = GPL-2.0+, BSD-2-Clause
 USB_MODESWITCH_LICENSE_FILES = COPYING
-# Package does not build in parallel due to improper make rules
-USB_MODESWITCH_MAKE = $(MAKE1)
 
 ifeq ($(BR2_PACKAGE_TCL)$(BR2_PACKAGE_TCL_SHLIB_ONLY),y)
 USB_MODESWITCH_DEPENDENCIES += tcl
-USB_MODESWITCH_BUILD_TARGETS = script
+USB_MODESWITCH_BUILD_TARGETS = all
 USB_MODESWITCH_INSTALL_TARGETS = install-script
 else
-USB_MODESWITCH_BUILD_TARGETS = static
-USB_MODESWITCH_INSTALL_TARGETS = install-static
+USB_MODESWITCH_DEPENDENCIES += jimtcl
+ifeq ($(BR2_STATIC_LIBS),y)
+USB_MODESWITCH_BUILD_TARGETS = all-with-statlink-dispatcher
+USB_MODESWITCH_INSTALL_TARGETS = install-statlink
+else
+USB_MODESWITCH_BUILD_TARGETS = all-with-dynlink-dispatcher
+USB_MODESWITCH_INSTALL_TARGETS = install-dynlink
+endif
 endif
-
-# build system of embedded jimtcl doesn't use autotools, but does use
-# an old version of gnuconfig which doesn't know all the architectures
-# supported by Buildroot, so update config.guess / config.sub like we
-# do in pkg-autotools.mk
-USB_MODESWITCH_POST_PATCH_HOOKS += UPDATE_CONFIG_HOOK
 
 define USB_MODESWITCH_BUILD_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
-               $(if $(BR2_INSTALL_LIBSTDCPP),,CXX=false) \
-               CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE -Wall -I." \
-               JIM_CONFIGURE_OPTS="--host=$(GNU_TARGET_NAME) --build=$(GNU_HOST_NAME)" \
                -C $(@D) $(USB_MODESWITCH_BUILD_TARGETS)
 endef