projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
e8fad4d
)
gdb: add back $ARCH-linux-gdb symlink for host-gdb
author
Peter Korsgaard
<jacmet@sunsite.dk>
Thu, 11 Apr 2013 21:09:13 +0000
(23:09 +0200)
committer
Peter Korsgaard
<jacmet@sunsite.dk>
Thu, 11 Apr 2013 21:09:13 +0000
(23:09 +0200)
Like we do for the toolchain and we used to to do for gdb.
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/gdb/gdb.mk
patch
|
blob
|
history
diff --git
a/package/gdb/gdb.mk
b/package/gdb/gdb.mk
index cec64d5c834758b41c0982e0ebe667ad96c81858..73ff7a465a5881cdc2640ab482d7891737e1ff26 100644
(file)
--- a/
package/gdb/gdb.mk
+++ b/
package/gdb/gdb.mk
@@
-111,5
+111,13
@@
HOST_GDB_CONF_OPT = \
--without-included-gettext \
--disable-sim
+# legacy $arch-linux-gdb symlink
+define HOST_GDB_ADD_SYMLINK
+ cd $(HOST_DIR)/usr/bin && \
+ ln -snf $(GNU_TARGET_NAME)-gdb $(ARCH)-linux-gdb
+endef
+
+HOST_GDB_POST_INSTALL_HOOKS += HOST_GDB_ADD_SYMLINK
+
$(eval $(autotools-package))
$(eval $(host-autotools-package))