Config.in: Add a menu around BR2_EXTERNAL configuration options
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 8 Dec 2013 22:21:50 +0000 (23:21 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 8 Dec 2013 22:30:26 +0000 (23:30 +0100)
To make it clear to the user that these options are external to Buildroot
and no support is provided by the Buildroot community.

With this, there's no need to recommend people to their options inside
a menu, so remove that from the documentation.

Kconfig nicely allows us to hide the menu completely if BR2_EXTERNAL isn't
used, so make use of that to not confuse people. It would be nice if we
could add some help text to explain the BR2_EXTERNAL stuff as well, but
that isn't supported on menus :/

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in
docs/manual/customize-outside-br.txt

index 12d36b5c83acb1c318b53db787e8a7971a2a423b..2b401cb8a2d1aa31b56fe4930760a440d0c53b6e 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -493,4 +493,9 @@ source "package/Config.in.host"
 
 source "Config.in.legacy"
 
+menu "User-provided options"
+       depends on BR2_EXTERNAL != "support/dummy-external"
+
 source "$BR2_EXTERNAL/Config.in"
+
+endmenu
index 0aabf5a9b50fb28bd961b5fc9a010fd4d1e35e29..19257e690ec57dceac8e200c627f0a59c63809c2 100644 (file)
@@ -89,12 +89,8 @@ The main usage of this is to store package recipes. The recommended
    like:
 +
 ------
-menu "<somecompany> packages"
-
 source "$BR2_EXTERNAL/package/package1/Config.in"
 source "$BR2_EXTERNAL/package/package2/Config.in"
-
-endmenu
 ------
 +
 Then, have a +BR2_EXTERNAL/external.mk+ file that looks like: