lua: bump to version 5.3.3
authorFrancois Perrad <fperrad@gmail.com>
Tue, 7 Jun 2016 16:29:15 +0000 (18:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 7 Jun 2016 19:31:30 +0000 (21:31 +0200)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lua/5.3.2/0001-root-path.patch [deleted file]
package/lua/5.3.2/0002-shared-libs-for-lua.patch [deleted file]
package/lua/5.3.2/0004-lua-pc.patch [deleted file]
package/lua/5.3.2/0011-linenoise.patch [deleted file]
package/lua/5.3.3/0001-root-path.patch [new file with mode: 0644]
package/lua/5.3.3/0002-shared-libs-for-lua.patch [new file with mode: 0644]
package/lua/5.3.3/0004-lua-pc.patch [new file with mode: 0644]
package/lua/5.3.3/0011-linenoise.patch [new file with mode: 0644]
package/lua/lua.hash
package/lua/lua.mk

diff --git a/package/lua/5.3.2/0001-root-path.patch b/package/lua/5.3.2/0001-root-path.patch
deleted file mode 100644 (file)
index d8ef8d0..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-Adjust installation location to /usr.
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/src/luaconf.h
-===================================================================
---- a/src/luaconf.h
-+++ b/src/luaconf.h
-@@ -188,7 +188,7 @@
-
- #else                 /* }{ */
-
--#define LUA_ROOT      "/usr/local/"
-+#define LUA_ROOT      "/usr/"
- #define LUA_LDIR      LUA_ROOT "share/lua/" LUA_VDIR "/"
- #define LUA_CDIR      LUA_ROOT "lib/lua/" LUA_VDIR "/"
- #define LUA_PATH_DEFAULT  \
diff --git a/package/lua/5.3.2/0002-shared-libs-for-lua.patch b/package/lua/5.3.2/0002-shared-libs-for-lua.patch
deleted file mode 100644 (file)
index 493828c..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-Add the compilation of a shared library.
-Compile the lua binary with the shared library.
-And install the shared library.
-The variable BUILDMODE allows to switch between static and dynamic mode.
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/Makefile
-===================================================================
---- a/Makefile
-+++ b/Makefile
-@@ -42,6 +42,7 @@
- TO_BIN= lua luac
- TO_INC= lua.h luaconf.h lualib.h lauxlib.h lua.hpp
- TO_LIB= liblua.a
-+TO_SOLIB = liblua.so.$(R)
- TO_MAN= lua.1 luac.1
- # Lua version and release.
-@@ -60,6 +61,8 @@
- install: dummy
-       cd src && $(MKDIR) $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB) $(INSTALL_MAN) $(INSTALL_LMOD) $(INSTALL_CMOD)
-       cd src && $(INSTALL_EXEC) $(TO_BIN) $(INSTALL_BIN)
-+      test -f src/$(TO_SOLIB) && cd src && $(INSTALL_EXEC) $(TO_SOLIB) $(INSTALL_LIB) || :
-+      test -f src/$(TO_SOLIB) && ln -sf $(TO_SOLIB) $(INSTALL_LIB)/liblua.so || :
-       cd src && $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
-       cd src && $(INSTALL_DATA) $(TO_LIB) $(INSTALL_LIB)
-       cd doc && $(INSTALL_DATA) $(TO_MAN) $(INSTALL_MAN)
-Index: b/src/Makefile
-===================================================================
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -29,6 +29,7 @@
- PLATS= aix bsd c89 freebsd generic linux macosx mingw posix solaris
- LUA_A=        liblua.a
-+LUA_SO=       liblua.so
- CORE_O=       lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o \
-       lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o \
-       ltm.o lundump.o lvm.o lzio.o
-@@ -43,8 +44,13 @@
- LUAC_O=       luac.o
- ALL_O= $(BASE_O) $(LUA_O) $(LUAC_O)
-+ifneq (dynamic,$(BUILDMODE))
- ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
-+else
-+ALL_T= $(LUA_A) $(LUA_SO) $(LUA_T) $(LUAC_T)
-+endif
- ALL_A= $(LUA_A)
-+ALL_SO= $(LUA_SO)
- # Targets start here.
- default: $(PLAT)
-@@ -55,12 +61,23 @@
- a:    $(ALL_A)
-+so:   $(ALL_SO)
-+
- $(LUA_A): $(BASE_O)
-       $(AR) $@ $(BASE_O)
-       $(RANLIB) $@
-+$(LUA_SO): $(CORE_O) $(LIB_O)
-+      $(CC) -o $@.$(PKG_VERSION) -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
-+      ln -fs $@.$(PKG_VERSION) $@
-+
-+ifneq (dynamic,$(BUILDMODE))
- $(LUA_T): $(LUA_O) $(LUA_A)
-       $(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
-+else
-+$(LUA_T): $(LUA_O) $(LUA_SO)
-+      $(CC) -o $@ -L. $(LDFLAGS) $(LUA_O) -llua $(LIBS)
-+endif
- $(LUAC_T): $(LUAC_O) $(LUA_A)
-       $(CC) -o $@ $(LDFLAGS) $(LUAC_O) $(LUA_A) $(LIBS)
diff --git a/package/lua/5.3.2/0004-lua-pc.patch b/package/lua/5.3.2/0004-lua-pc.patch
deleted file mode 100644 (file)
index 811d931..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-add lua.pc
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/etc/lua.pc
-===================================================================
---- /dev/null
-+++ b/etc/lua.pc
-@@ -0,0 +1,31 @@
-+# lua.pc -- pkg-config data for Lua
-+
-+# vars from install Makefile
-+
-+# grep '^V=' ../Makefile
-+V= 5.3
-+# grep '^R=' ../Makefile
-+R= 5.3.2
-+
-+# grep '^INSTALL_.*=' ../Makefile | sed 's/INSTALL_TOP/prefix/'
-+prefix= /usr
-+INSTALL_BIN= ${prefix}/bin
-+INSTALL_INC= ${prefix}/include
-+INSTALL_LIB= ${prefix}/lib
-+INSTALL_MAN= ${prefix}/man/man1
-+INSTALL_LMOD= ${prefix}/share/lua/${V}
-+INSTALL_CMOD= ${prefix}/lib/lua/${V}
-+
-+# canonical vars
-+exec_prefix=${prefix}
-+libdir=${exec_prefix}/lib
-+includedir=${prefix}/include
-+
-+Name: Lua
-+Description: An Extensible Extension Language
-+Version: ${R}
-+Requires: 
-+Libs: -L${libdir} -llua -lm
-+Cflags: -I${includedir}
-+
-+# (end of lua.pc)
diff --git a/package/lua/5.3.2/0011-linenoise.patch b/package/lua/5.3.2/0011-linenoise.patch
deleted file mode 100644 (file)
index f3ced2b..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-Add support of linenoise (replace readline)
-
-see discussion, http://lua-users.org/lists/lua-l/2010-03/msg00879.html
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/src/lua.c
-===================================================================
---- a/src/lua.c
-+++ b/src/lua.c
-@@ -83,6 +83,13 @@
- #define lua_saveline(L,line)  ((void)L, add_history(line))
- #define lua_freeline(L,b)     ((void)L, free(b))
-+#elif defined(LUA_USE_LINENOISE)
-+
-+#include <linenoise.h>
-+#define lua_readline(L,b,p)   ((void)L, ((b)=linenoise(p)) != NULL)
-+#define lua_saveline(L,line)  ((void)L, linenoiseHistoryAdd(line))
-+#define lua_freeline(L,b)     ((void)L, free(b))
-+
- #else                         /* }{ */
- #define lua_readline(L,b,p) \
diff --git a/package/lua/5.3.3/0001-root-path.patch b/package/lua/5.3.3/0001-root-path.patch
new file mode 100644 (file)
index 0000000..d8ef8d0
--- /dev/null
@@ -0,0 +1,17 @@
+Adjust installation location to /usr.
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+
+Index: b/src/luaconf.h
+===================================================================
+--- a/src/luaconf.h
++++ b/src/luaconf.h
+@@ -188,7 +188,7 @@
+
+ #else                 /* }{ */
+
+-#define LUA_ROOT      "/usr/local/"
++#define LUA_ROOT      "/usr/"
+ #define LUA_LDIR      LUA_ROOT "share/lua/" LUA_VDIR "/"
+ #define LUA_CDIR      LUA_ROOT "lib/lua/" LUA_VDIR "/"
+ #define LUA_PATH_DEFAULT  \
diff --git a/package/lua/5.3.3/0002-shared-libs-for-lua.patch b/package/lua/5.3.3/0002-shared-libs-for-lua.patch
new file mode 100644 (file)
index 0000000..493828c
--- /dev/null
@@ -0,0 +1,78 @@
+Add the compilation of a shared library.
+Compile the lua binary with the shared library.
+And install the shared library.
+The variable BUILDMODE allows to switch between static and dynamic mode.
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -42,6 +42,7 @@
+ TO_BIN= lua luac
+ TO_INC= lua.h luaconf.h lualib.h lauxlib.h lua.hpp
+ TO_LIB= liblua.a
++TO_SOLIB = liblua.so.$(R)
+ TO_MAN= lua.1 luac.1
+ # Lua version and release.
+@@ -60,6 +61,8 @@
+ install: dummy
+       cd src && $(MKDIR) $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB) $(INSTALL_MAN) $(INSTALL_LMOD) $(INSTALL_CMOD)
+       cd src && $(INSTALL_EXEC) $(TO_BIN) $(INSTALL_BIN)
++      test -f src/$(TO_SOLIB) && cd src && $(INSTALL_EXEC) $(TO_SOLIB) $(INSTALL_LIB) || :
++      test -f src/$(TO_SOLIB) && ln -sf $(TO_SOLIB) $(INSTALL_LIB)/liblua.so || :
+       cd src && $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
+       cd src && $(INSTALL_DATA) $(TO_LIB) $(INSTALL_LIB)
+       cd doc && $(INSTALL_DATA) $(TO_MAN) $(INSTALL_MAN)
+Index: b/src/Makefile
+===================================================================
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -29,6 +29,7 @@
+ PLATS= aix bsd c89 freebsd generic linux macosx mingw posix solaris
+ LUA_A=        liblua.a
++LUA_SO=       liblua.so
+ CORE_O=       lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o \
+       lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o \
+       ltm.o lundump.o lvm.o lzio.o
+@@ -43,8 +44,13 @@
+ LUAC_O=       luac.o
+ ALL_O= $(BASE_O) $(LUA_O) $(LUAC_O)
++ifneq (dynamic,$(BUILDMODE))
+ ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
++else
++ALL_T= $(LUA_A) $(LUA_SO) $(LUA_T) $(LUAC_T)
++endif
+ ALL_A= $(LUA_A)
++ALL_SO= $(LUA_SO)
+ # Targets start here.
+ default: $(PLAT)
+@@ -55,12 +61,23 @@
+ a:    $(ALL_A)
++so:   $(ALL_SO)
++
+ $(LUA_A): $(BASE_O)
+       $(AR) $@ $(BASE_O)
+       $(RANLIB) $@
++$(LUA_SO): $(CORE_O) $(LIB_O)
++      $(CC) -o $@.$(PKG_VERSION) -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
++      ln -fs $@.$(PKG_VERSION) $@
++
++ifneq (dynamic,$(BUILDMODE))
+ $(LUA_T): $(LUA_O) $(LUA_A)
+       $(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
++else
++$(LUA_T): $(LUA_O) $(LUA_SO)
++      $(CC) -o $@ -L. $(LDFLAGS) $(LUA_O) -llua $(LIBS)
++endif
+ $(LUAC_T): $(LUAC_O) $(LUA_A)
+       $(CC) -o $@ $(LDFLAGS) $(LUAC_O) $(LUA_A) $(LIBS)
diff --git a/package/lua/5.3.3/0004-lua-pc.patch b/package/lua/5.3.3/0004-lua-pc.patch
new file mode 100644 (file)
index 0000000..edf7ec3
--- /dev/null
@@ -0,0 +1,40 @@
+add lua.pc
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+
+Index: b/etc/lua.pc
+===================================================================
+--- /dev/null
++++ b/etc/lua.pc
+@@ -0,0 +1,31 @@
++# lua.pc -- pkg-config data for Lua
++
++# vars from install Makefile
++
++# grep '^V=' ../Makefile
++V= 5.3
++# grep '^R=' ../Makefile
++R= 5.3.3
++
++# grep '^INSTALL_.*=' ../Makefile | sed 's/INSTALL_TOP/prefix/'
++prefix= /usr
++INSTALL_BIN= ${prefix}/bin
++INSTALL_INC= ${prefix}/include
++INSTALL_LIB= ${prefix}/lib
++INSTALL_MAN= ${prefix}/man/man1
++INSTALL_LMOD= ${prefix}/share/lua/${V}
++INSTALL_CMOD= ${prefix}/lib/lua/${V}
++
++# canonical vars
++exec_prefix=${prefix}
++libdir=${exec_prefix}/lib
++includedir=${prefix}/include
++
++Name: Lua
++Description: An Extensible Extension Language
++Version: ${R}
++Requires:
++Libs: -L${libdir} -llua -lm
++Cflags: -I${includedir}
++
++# (end of lua.pc)
diff --git a/package/lua/5.3.3/0011-linenoise.patch b/package/lua/5.3.3/0011-linenoise.patch
new file mode 100644 (file)
index 0000000..f3ced2b
--- /dev/null
@@ -0,0 +1,24 @@
+Add support of linenoise (replace readline)
+
+see discussion, http://lua-users.org/lists/lua-l/2010-03/msg00879.html
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+
+Index: b/src/lua.c
+===================================================================
+--- a/src/lua.c
++++ b/src/lua.c
+@@ -83,6 +83,13 @@
+ #define lua_saveline(L,line)  ((void)L, add_history(line))
+ #define lua_freeline(L,b)     ((void)L, free(b))
++#elif defined(LUA_USE_LINENOISE)
++
++#include <linenoise.h>
++#define lua_readline(L,b,p)   ((void)L, ((b)=linenoise(p)) != NULL)
++#define lua_saveline(L,line)  ((void)L, linenoiseHistoryAdd(line))
++#define lua_freeline(L,b)     ((void)L, free(b))
++
+ #else                         /* }{ */
+ #define lua_readline(L,b,p) \
index 8f0242e02d584cf26998974d82b6c881278394c0..04459e9e41a99bd317d3d154593f039c4f4bd0b8 100644 (file)
@@ -1,6 +1,6 @@
 # Hashes from: http://www.lua.org/ftp/
-md5 33278c2ab5ee3c1a875be8d55c1ca2a1           lua-5.3.2.tar.gz
-sha1 7a47adef554fdca7d0c5536148de34579134a973  lua-5.3.2.tar.gz
+md5 703f75caa4fdf4a911c1a72e67a27498           lua-5.3.3.tar.gz
+sha1 a0341bc3d1415b814cc738b2ec01ae56045d64ef  lua-5.3.3.tar.gz
 
 md5 913fdb32207046b273fdb17aad70be13           lua-5.2.4.tar.gz
 sha1 ef15259421197e3d85b7d6e4871b8c26fd82c1cf  lua-5.2.4.tar.gz
index 37992f26ab3fa6e395f6f73d1ed124804b7cb978..b2dab3937c4598e0907a1e1e2815fffecfb78d85 100644 (file)
@@ -5,7 +5,7 @@
 ################################################################################
 
 ifeq ($(BR2_PACKAGE_LUA_5_3),y)
-LUA_VERSION = 5.3.2
+LUA_VERSION = 5.3.3
 else
 ifeq ($(BR2_PACKAGE_LUA_5_2),y)
 LUA_VERSION = 5.2.4