package/uclibc: drop BR2_TOOLCHAIN_BUILDROOT_LARGEFILE
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 30 Mar 2015 21:07:33 +0000 (18:07 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 1 Apr 2015 20:53:18 +0000 (22:53 +0200)
Kill the option to build the non-largefile variant and remove the hidden
option since it's now unused.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/uclibc/Config.in
package/uclibc/uclibc.mk

index e4405598c56ce564e59f7dd9042d6217cf766549..fdf835142d5b438189bfa368db021cd1537466e2 100644 (file)
@@ -86,11 +86,6 @@ config BR2_UCLIBC_CONFIG
          See also docs/README in this package.
          If unsure, use the default.
 
-config BR2_TOOLCHAIN_BUILDROOT_LARGEFILE
-       bool
-       select BR2_LARGEFILE
-       default y
-
 config BR2_TOOLCHAIN_BUILDROOT_INET_IPV6
        bool "Enable IPv6 support"
        select BR2_INET_IPV6
index 2b5a64297280db0955dd93b985dcad583b2eb7f9..72a46d963bcfb95cda566f1ec5a768394a89df2a 100644 (file)
@@ -190,16 +190,9 @@ endif
 # Largefile
 #
 
-ifeq ($(BR2_TOOLCHAIN_BUILDROOT_LARGEFILE),y)
 define UCLIBC_LARGEFILE_CONFIG
        $(call KCONFIG_ENABLE_OPT,UCLIBC_HAS_LFS,$(@D)/.config)
 endef
-else
-define UCLIBC_LARGEFILE_CONFIG
-       $(call KCONFIG_DISABLE_OPT,UCLIBC_HAS_LFS,$(@D)/.config)
-       $(call KCONFIG_DISABLE_OPT,UCLIBC_HAS_FOPEN_LARGEFILE_MODE,$(@D)/.config)
-endef
-endif
 
 #
 # MMU