package/systemd: add optional support for timedated
authorGabe Evans <gabe@hashrabbit.co>
Fri, 1 Jul 2016 21:51:11 +0000 (23:51 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 2 Jul 2016 10:40:58 +0000 (12:40 +0200)
Signed-off-by: Gabe Evans <gabe@hashrabbit.co>
[Maxime: Add default y]
Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/systemd/Config.in
package/systemd/systemd.mk

index 1be0a967728d25f92541bb41e7bb0b676c894b72..e84a7170c8b555d1b85c7124dbc231553a025786 100644 (file)
@@ -225,6 +225,16 @@ config BR2_PACKAGE_SYSTEMD_HOSTNAMED
 
          http://www.freedesktop.org/software/systemd/man/systemd-hostnamed.service.html
 
+config BR2_PACKAGE_SYSTEMD_TIMEDATED
+       bool "enable timedate daemon"
+       default y
+       help
+         systemd-timedated is a system service that may be used as a
+         mechanism to change the system clock and timezone, as well
+         as to enable/disable NTP time synchronization.
+
+         http://www.freedesktop.org/software/systemd/man/systemd-timedated.service.html
+
 config BR2_PACKAGE_SYSTEMD_NETWORKD
        bool "enable network manager"
        help
index 5e58017962fecb733aeeafda38642161beab6bd5..ad75315238d5d1c69b33d4cac90c73072dd7a012 100644 (file)
@@ -219,6 +219,12 @@ else
 SYSTEMD_CONF_OPTS += --disable-hostnamed
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD_TIMEDATED),y)
+SYSTEMD_CONF_OPTS += --enable-timedated
+else
+SYSTEMD_CONF_OPTS += --disable-timedated
+endif
+
 ifeq ($(BR2_PACKAGE_SYSTEMD_NETWORKD),y)
 SYSTEMD_CONF_OPTS += --enable-networkd
 define SYSTEMD_INSTALL_RESOLVCONF_HOOK