gmp/mpfr: make sure host builds add source targets to HOST_SOURCE
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 25 Feb 2010 16:27:50 +0000 (17:27 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 25 Feb 2010 16:27:50 +0000 (17:27 +0100)
Closes #1183.

When gmp/mpfr is needed for the host (E.G. when using an internal toolchain),
the host-lib{gmp,mpfr}-source targets weren't added to HOST_SOURCE, so
make source / external-deps didn't handle them.

Notice that we have the same issue with the new host package support,
there we should probably use HOST_<package>_DEPENDENCIES for -source
dependencies.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/gmp/gmp.mk
package/mpfr/mpfr.mk
toolchain/binutils/binutils.mk
toolchain/gcc/gcc-uclibc-4.x.mk

diff --git a/CHANGES b/CHANGES
index 402c9473faa67a91ba222c33c3f405723e3d4c67..4709fdfe502b68962341c6fdcc4bef355c93e08f 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,7 @@
        Issues resolved (http://bugs.uclibc.org):
 
        #165: openmotif does not build
+       #1183: make source fails to download gmp, mpfr and patches
 
 2010.02-rc2, Released February 23th, 2010:
 
index 7ae78c79d08be0d4a1e60eaf082efcabae6c03cc..a3488b8369c18a5f7409df47f060df24b54547be 100644 (file)
@@ -93,6 +93,7 @@ $(GMP_HOST_DIR)/lib/libgmp$(HOST_LIBEXT): $(GMP_DIR2)/.configured
        $(MAKE) -C $(GMP_DIR2) install
 
 host-libgmp: $(GMP_HOST_DIR)/lib/$(GMP_HOST_BINARY)
+host-libgmp-source: libgmp-source
 host-libgmp-clean:
        rm -rf $(GMP_HOST_DIR)
        -$(MAKE) -C $(GMP_DIR2) clean
index 595edc3cb793c979faf40f4174d2fe898afa0d04..a7834dd9bc314ca6217e588d8b513d03da522118 100644 (file)
@@ -107,6 +107,7 @@ $(MPFR_HOST_DIR)/lib/libmpfr$(HOST_LIBEXT): $(MPFR_DIR2)/.configured
        $(MAKE) -C $(MPFR_DIR2) install
 
 host-libmpfr: $(MPFR_HOST_DIR)/lib/$(MPFR_HOST_BINARY)
+host-libmpfr-source: libmpfr-source
 host-libmpfr-clean:
        rm -rf $(MPFR_HOST_DIR)
        -$(MAKE) -C $(MPFR_DIR2) clean
index 288a000f5de4f16df7011aac713ab3d869c5c119..77e7d3d5187ced683d339ae51921a5f1e697e849 100644 (file)
@@ -37,6 +37,7 @@ endif
 ifndef BINUTILS_NO_MPFR
 BINUTILS_HOST_PREREQ:=$(TOOLCHAIN_DIR)/gmp/lib/libgmp$(HOST_LIBEXT) \
        $(TOOLCHAIN_DIR)/mpfr/lib/libmpfr$(HOST_LIBEXT)
+HOST_SOURCE += host-libgmp-source host-libmpfr-source
 
 BINUTILS_TARGET_PREREQ:=$(TARGET_DIR)/usr/lib/libgmp$(LIBTGTEXT) \
        $(TARGET_DIR)/usr/lib/libmpfr$(LIBTGTEXT)
index dcca431dba9a54e40645b856025b6f4c14e207ef..cf76e8ad156e305ebf081897bb47e6d58b8f469a 100644 (file)
@@ -107,6 +107,7 @@ endif
 ifndef GCC_NO_MPFR
 GCC_WITH_HOST_GMP=--with-gmp=$(GMP_HOST_DIR)
 GCC_WITH_HOST_MPFR=--with-mpfr=$(MPFR_HOST_DIR)
+HOST_SOURCE += host-libgmp-source host-libmpfr-source
 
 ifeq ($(BR2_INSTALL_FORTRAN),y)
 GCC_TARGET_LANGUAGES:=$(GCC_TARGET_LANGUAGES),fortran