cloop: convert to ROOTFS_TARGET infrastructure
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 9 Mar 2010 23:13:12 +0000 (00:13 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 9 Apr 2010 09:04:34 +0000 (11:04 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
target/cloop/cloop.mk

index ccdb2b49195924c4310454c98e4e37d4b40aa823..c1d6abb80201025f2e8cb487b3ea1eaef6b7824e 100644 (file)
@@ -4,26 +4,10 @@
 #
 #############################################################
 
-CLOOP_TARGET=$(IMAGE).cloop
-CLOOP_FAKEROOT_SCRIPT=$(BUILD_DIR)/_fakeroot.$(notdir $(CLOOP_TARGET))
+ROOTFS_CLOOP_DEPENDENCIES = host-cloop host-cdrkit
 
-clooproot: host-cloop host-cdrkit host-fakeroot
-       rm -f $(CLOOP_FAKEROOT_SCRIPT)
-       touch $(BUILD_DIR)/.fakeroot.00000
-       cat $(BUILD_DIR)/.fakeroot* > $(CLOOP_FAKEROOT_SCRIPT)
-       # Use fakeroot to pretend all target binaries are owned by root
-       echo "chown -R 0:0 $(TARGET_DIR)" >> $(CLOOP_FAKEROOT_SCRIPT)
-ifneq ($(TARGET_DEVICE_TABLE),)
-       # Use fakeroot to pretend to create all needed device nodes
-       echo "$(HOST_DIR)/usr/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" \
-               >> $(CLOOP_FAKEROOT_SCRIPT)
-endif
-       # Use fakeroot so genisoimage believes the previous fakery
-       echo "$(HOST_DIR)/usr/bin/genisoimage -r $(TARGET_DIR) | $(HOST_DIR)/usr/bin/create_compressed_fs - 65536 > $(CLOOP_TARGET)" >> $(CLOOP_FAKEROOT_SCRIPT)
-       chmod a+x $(CLOOP_FAKEROOT_SCRIPT)
-       $(HOST_DIR)/usr/bin/fakeroot -- $(CLOOP_FAKEROOT_SCRIPT)
-       -@rm -f $(CLOOP_FAKEROOT_SCRIPT)
+define ROOTFS_CLOOP_CMD
+       $(HOST_DIR)/usr/bin/genisoimage -r $(TARGET_DIR) | $(HOST_DIR)/usr/bin/create_compressed_fs - 65536 > $$@
+endef
 
-ifeq ($(BR2_TARGET_ROOTFS_CLOOP),y)
-TARGETS+=clooproot
-endif
+$(eval $(call ROOTFS_TARGET,cloop))
\ No newline at end of file