package/cracklib: add python3 support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 2 Feb 2020 20:53:06 +0000 (21:53 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 19 May 2020 19:01:13 +0000 (21:01 +0200)
python bindings supports python3 since version 2.8.19 and
https://github.com/cracklib/cracklib/commit/219de98766b9f1e4c8c5b174de770158ffda3a93

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/cracklib/cracklib.mk

index 91d510ff3423570d88219c3f5fadb66817641c4a..be1b50f1387b8bda0f9e4a50fdb44c943fb49f31 100644 (file)
@@ -19,9 +19,9 @@ else
 CRACKLIB_CONF_OPTS += --without-zlib
 endif
 
-ifeq ($(BR2_PACKAGE_PYTHON),y)
+ifeq ($(BR2_PACKAGE_PYTHON)$(BR2_PACKAGE_PYTHON3),y)
 CRACKLIB_CONF_OPTS += --with-python
-CRACKLIB_DEPENDENCIES += python
+CRACKLIB_DEPENDENCIES += $(if $(BR2_PACKAGE_PYTHON),python,python3)
 else
 CRACKLIB_CONF_OPTS += --without-python
 endif