package/glmark2: Wayland-gl support also needs egl
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 29 Nov 2015 12:57:38 +0000 (13:57 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 29 Nov 2015 13:26:39 +0000 (14:26 +0100)
We were missing the egl dependency when enabling Wayland GL support:
https://github.com/glmark2/glmark2/blob/master/src/wscript_build#L28

Fixes
http://autobuild.buildroot.net/results/858/8587d0cea86efa4c6e98817cadc7cce0b1b36e3d/
http://autobuild.buildroot.net/results/1f6/1f6853d5f7a83be60ccdf4f071a1df1491cf8137/
http://autobuild.buildroot.net/results/a4d/a4d830291ee8550b3c544ade7169218d5edd4d52/
http://autobuild.buildroot.net/results/536/536a8dc62783633943770a278dc9f1c6c5c0807c/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/glmark2/glmark2.mk

index a2e88523a39438e56eb2955734520f548ae0462f..bd5b51a3f887dd1afbdecafd4cf4371739db00ee 100644 (file)
@@ -36,7 +36,7 @@ GLMARK2_DEPENDENCIES += wayland
 GLMARK2_FLAVORS += wayland-glesv2
 endif
 
-ifeq ($(BR2_PACKAGE_WAYLAND)$(BR2_PACKAGE_HAS_LIBGL),yy)
+ifeq ($(BR2_PACKAGE_WAYLAND)$(BR2_PACKAGE_HAS_LIBEGL)$(BR2_PACKAGE_HAS_LIBGL),yyy)
 GLMARK2_DEPENDENCIES += wayland
 GLMARK2_FLAVORS += wayland-gl
 endif